HighFix available
ghostscript — security advisory
An issue was discovered in Artifex Ghostscript before 9.24. Incorrect exec stack handling in the "CS" and "SC" PDF primitives could be used by remote attackers able to supply crafted PDFs to crash the interpreter or possibly have unspecified other impact.
- Products
- ghostscript
- Affected versions
- Not specified
- Fixed versions
- 9.25~dfsg-1
- CVEs
- CVE-2018-16510
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 00:08 UTC · Revision 1
Source evidence
An issue was discovered in Artifex Ghostscript before 9.24. Incorrect exec stack handling in the "CS" and "SC" PDF primitives could be used by remote attackers able to supply crafted PDFs to crash the interpreter or possibly have unspecified other impact.
osv:DEBIAN-CVE-2018-16510
ghostscript
Fixed versions: 9.25~dfsg-1
ghostscript
Fixed versions: 9.25~dfsg-1
ghostscript
Fixed versions: 9.25~dfsg-1
Complete source record
{
"id": "e166391e80fb272b2b70419bdbbb04792ec4a99fca145e96990523068b5c84c4",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2018-16510",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2018-16510",
"summary": "An issue was discovered in Artifex Ghostscript before 9.24. Incorrect exec stack handling in the \"CS\" and \"SC\" PDF primitives could be used by remote attackers able to supply crafted PDFs to crash the interpreter or possibly have unspecified other impact.",
"evidence": "osv:DEBIAN-CVE-2018-16510",
"products": [
{
"name": {
"value": "ghostscript",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "9.25~dfsg-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ghostscript",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "9.25~dfsg-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ghostscript",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "9.25~dfsg-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2018-16510",
"aliases": [
"DEBIAN-CVE-2018-16510"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "9.25~dfsg-1"
}
]
}
],
"package": {
"name": "ghostscript",
"purl": "pkg:deb/debian/ghostscript?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-16510.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "9.25~dfsg-1"
}
]
}
],
"package": {
"name": "ghostscript",
"purl": "pkg:deb/debian/ghostscript?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-16510.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "9.25~dfsg-1"
}
]
}
],
"package": {
"name": "ghostscript",
"purl": "pkg:deb/debian/ghostscript?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-16510.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:03:00.722315626Z",
"provider": "osv",
"upstream": [
"CVE-2018-16510"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2018-16510"
]
},
"related_cves": [
{
"value": "CVE-2018-16510",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 420106,
"published_at": "2018-09-05T06:29:00.75+00:00"
}