Weave Gitops Run vulnerable to insecure communication
Weave GitOps is a simple open source developer platform for people who want cloud native applications, without needing Kubernetes expertise. GitOps run has a local S3 bucket which it uses for synchronizing files that are later applied against a Kubernetes cluster. The communication between GitOps Run and the local S3 bucket is not encrypted. This allows privileged users or process to tap the local traffic to gain information permitting access to the s3 bucket. From that point, it would be possible to alter the bucket content, resulting in changes in the Kubernetes cluster's resources. There are no known workaround(s) for this vulnerability. This vulnerability has been fixed by commits ce2bbff and babd915. Users should upgrade to Weave GitOps version >= v0.12.0 released on 08/12/2022.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-23509
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 20:45 UTC · Revision 1
Source evidence
Weave Gitops Run vulnerable to insecure communication
core-osv · Original sourcePublished 9 Jan 2023, 13:01 UTC
Weave GitOps is a simple open source developer platform for people who want cloud native applications, without needing Kubernetes expertise. GitOps run has a local S3 bucket which it uses for synchronizing files that are later applied against a Kubernetes cluster. The communication between GitOps Run and the local S3 bucket is not encrypted. This allows privileged users or process to tap the local traffic to gain information permitting access to the s3 bucket. From that point, it would be possible to alter the bucket content, resulting in changes in the Kubernetes cluster's resources. There are no known workaround(s) for this vulnerability. This vulnerability has been fixed by commits ce2bbff and babd915. Users should upgrade to Weave GitOps version >= v0.12.0 released on 08/12/2022.
osv:CVE-2022-23509
Complete source record
{
"id": "d1d3110fb1954e047ce4407a5d85cfa8026a9285ca32b1664453746fb81eb45e",
"url": "https://osv.dev/vulnerability/CVE-2022-23509",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Weave Gitops Run vulnerable to insecure communication",
"summary": "Weave GitOps is a simple open source developer platform for people who want cloud native applications, without needing Kubernetes expertise. GitOps run has a local S3 bucket which it uses for synchronizing files that are later applied against a Kubernetes cluster. The communication between GitOps Run and the local S3 bucket is not encrypted. This allows privileged users or process to tap the local traffic to gain information permitting access to the s3 bucket. From that point, it would be possible to alter the bucket content, resulting in changes in the Kubernetes cluster's resources. There are no known workaround(s) for this vulnerability. This vulnerability has been fixed by commits ce2bbff and babd915. Users should upgrade to Weave GitOps version >= v0.12.0 released on 08/12/2022.",
"evidence": "osv:CVE-2022-23509",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2022-23509",
"aliases": [
"CVE-2022-23509",
"GHSA-89qm-wcmw-3mgg",
"GO-2023-1388"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/weaveworks/weave-gitops",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "eeb3a50c4b0bc98335fe3544e0c704b31377a52f"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"last_affected": "0.11.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"cpe": "cpe:2.3:a:weave:weave_gitops:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "0.12.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v0.8.1-rc.2",
"v0.7.0-rc12",
"v0.7.0-rc11",
"v0.7.0-rc9",
"v0.7.0-rc8",
"v0.7.0-rc7",
"v0.7.0-rc5",
"v0.7.0-rc4",
"v0.7.0-rc3",
"v0.7.0-rc2",
"v0.7.0-rc1",
"v0.6.2",
"v0.6.1",
"v0.6.1-rc1",
"v0.6.0",
"v0.6.0-rc1",
"v0.6.0-rc0",
"v0.5.1-rc3",
"v0.5.1-rc2",
"v0.5.1-rc1",
"v0.5.1-rc0",
"v0.5.1-rc0.5.0",
"v0.5.0",
"v0.5.0-rc2",
"v0.5.0-rc1",
"v0.5.0-rc0.4.1",
"v0.4.1",
"v0.4.1-rc0",
"v0.4.0",
"v0.4.0-rc0",
"v0.3.3",
"v0.3.3-rc0",
"v0.3.2",
"v0.3.2-rc1",
"v0.3.2-rc",
"v0.3.1",
"v0.3.0",
"v0.2.5",
"v0.2.4",
"v0.2.3",
"v0.2.2",
"v0.2.2-rc",
"v0.2.1",
"v0.2.0",
"v0.1.0",
"v0.1.0-rc.2",
"v0.1.0-rc.1",
"v0.1.0-rc0",
"v0.0.5",
"v0.0.4",
"v0.0.3",
"v0.0.2",
"v0.0.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-23509.json"
}
}
],
"modified": "2026-10-28T02:30:23.561256680Z",
"provider": "osv",
"references": [
"https://github.com/weaveworks/weave-gitops/pull/3098/commits/babd91574b99b310b84aeec9f8f895bd18acb967",
"https://github.com/weaveworks/weave-gitops/pull/3106/commits/ce2bbff0a3609c33396050ed544a5a21f8d0797f",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/23xxx/CVE-2022-23509.json",
"https://github.com/weaveworks/weave-gitops/security/advisories/GHSA-89qm-wcmw-3mgg",
"https://nvd.nist.gov/vuln/detail/CVE-2022-23509"
],
"provider_metadata": {
"cwe_ids": [
"CWE-200"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/23xxx/CVE-2022-23509.json"
}
},
"related_cves": [
{
"value": "CVE-2022-23509",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 489992,
"published_at": "2023-01-09T13:01:08.474+00:00"
}