Skip to content
Heist/ feed
Back to feed
High

Persistent Cross-site Scripting (XSS) vulnerability in PrivateBin

Type: advisorySources: OSV

PrivateBin is minimalist, open source online pastebin clone where the server has zero knowledge of pasted data. In PrivateBin < v1.4.0 a cross-site scripting (XSS) vulnerability was found. The vulnerability is present in all versions from v0.21 of the project, which was at the time still called ZeroBin. The issue is caused by the fact that SVGs can contain JavaScript. This can allow an attacker to execute code, if the user opens a paste with a specifically crafted SVG attachment, and interacts with the preview image and the instance isn't protected by an appropriate content security policy. Users are advised to either upgrade to version 1.4.0 or to ensure the content security policy of their instance is set correctly.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2022-24833
Confirmed fixed CVEs
Not specified
Updated in this feed
2 Nov 2026, 23:31 UTC · Revision 1

Source evidence

Persistent Cross-site Scripting (XSS) vulnerability in PrivateBin

core-osv · Original source

Published 11 Apr 2022, 20:20 UTC

PrivateBin is minimalist, open source online pastebin clone where the server has zero knowledge of pasted data. In PrivateBin < v1.4.0 a cross-site scripting (XSS) vulnerability was found. The vulnerability is present in all versions from v0.21 of the project, which was at the time still called ZeroBin. The issue is caused by the fact that SVGs can contain JavaScript. This can allow an attacker to execute code, if the user opens a paste with a specifically crafted SVG attachment, and interacts with the preview image and the instance isn't protected by an appropriate content security policy. Users are advised to either upgrade to version 1.4.0 or to ensure the content security policy of their instance is set correctly.

osv:CVE-2022-24833
Complete source record
{
  "id": "3d887c29e7cc11378ea060126995eb397bac8ecb4882df2f0909498920988b33",
  "url": "https://osv.dev/vulnerability/CVE-2022-24833",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Persistent Cross-site Scripting (XSS) vulnerability in PrivateBin",
    "summary": "PrivateBin is minimalist, open source online pastebin clone where the server has zero knowledge of pasted data. In PrivateBin < v1.4.0 a cross-site scripting (XSS) vulnerability was found. The vulnerability is present in all versions from v0.21 of the project, which was at the time still called ZeroBin. The issue is caused by the fact that SVGs can contain JavaScript. This can allow an attacker to execute code, if the user opens a paste with a specifically crafted SVG attachment, and interacts with the preview image and the instance isn't protected by an appropriate content security policy. Users are advised to either upgrade to version 1.4.0 or to ensure the content security policy of their instance is set correctly.",
    "evidence": "osv:CVE-2022-24833",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2022-24833",
      "aliases": [
        "CVE-2022-24833",
        "GHSA-cqcc-mm6x-vmvw"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/privatebin/privatebin",
              "type": "GIT",
              "events": [
                {
                  "introduced": "2dd8b94b05a2ecaab3b39f7967012cc30be9ed62"
                },
                {
                  "fixed": "7ce853001db669cca339228b0cf865e12195c998"
                },
                {
                  "fixed": "2a4d572c1e9eb9b608d32b0cc0cb3b6c3b684eab"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:privatebin:privatebin:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0.21"
                      },
                      {
                        "fixed": "1.4.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "2a4d572c1e9eb9b608d32b0cc0cb3b6c3b684eab"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "1.3.5",
            "1.3.4",
            "1.3.3",
            "1.3.2",
            "1.2.1",
            "1.3.1",
            "1.3",
            "1.1",
            "1.0",
            "0.22",
            "0.21.1",
            "0.21"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-24833.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:24.471130272Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/24xxx/CVE-2022-24833.json",
        "https://github.com/PrivateBin/PrivateBin/security/advisories/GHSA-cqcc-mm6x-vmvw",
        "https://nvd.nist.gov/vuln/detail/CVE-2022-24833",
        "https://github.com/PrivateBin/PrivateBin/commit/2a4d572c1e9eb9b608d32b0cc0cb3b6c3b684eab"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/24xxx/CVE-2022-24833.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2022-24833",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 490903,
  "published_at": "2022-04-11T20:20:33+00:00"
}