Apache RocketMQ: Unauthorized Exposure of Sensitive Data
For RocketMQ versions 5.2.0 and below, under certain conditions, there is a risk of exposure of sensitive Information to an unauthorized actor even if RocketMQ is enabled with authentication and authorization functions. An attacker, possessing regular user privileges or listed in the IP whitelist, could potentially acquire the administrator's account and password through specific interfaces. Such an action would grant them full control over RocketMQ, provided they have access to the broker IP address list. To mitigate these security threats, it is strongly advised that users upgrade to version 5.3.0 or newer. Additionally, we recommend users to use RocketMQ ACL 2.0 instead of the original RocketMQ ACL when upgrading to version Apache RocketMQ 5.3.0.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-23321
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 14:03 UTC · Revision 1
Source evidence
Apache RocketMQ: Unauthorized Exposure of Sensitive Data
core-osv · Original sourcePublished 22 Jul 2024, 09:24 UTC
For RocketMQ versions 5.2.0 and below, under certain conditions, there is a risk of exposure of sensitive Information to an unauthorized actor even if RocketMQ is enabled with authentication and authorization functions. An attacker, possessing regular user privileges or listed in the IP whitelist, could potentially acquire the administrator's account and password through specific interfaces. Such an action would grant them full control over RocketMQ, provided they have access to the broker IP address list. To mitigate these security threats, it is strongly advised that users upgrade to version 5.3.0 or newer. Additionally, we recommend users to use RocketMQ ACL 2.0 instead of the original RocketMQ ACL when upgrading to version Apache RocketMQ 5.3.0.
osv:CVE-2024-23321
Complete source record
{
"id": "0273fc3783f23c3eefea142cd58dd7987b136df725e0abce9a543dcceeefb2fa",
"url": "https://osv.dev/vulnerability/CVE-2024-23321",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache RocketMQ: Unauthorized Exposure of Sensitive Data",
"summary": "For RocketMQ versions 5.2.0 and below, under certain conditions, there is a risk of exposure of sensitive Information to an unauthorized actor even if RocketMQ is enabled with authentication and authorization functions. An attacker, possessing regular user privileges or listed in the IP whitelist, could potentially acquire the administrator's account and password through specific interfaces. Such an action would grant them full control over RocketMQ, provided they have access to the broker IP address list. To mitigate these security threats, it is strongly advised that users upgrade to version 5.3.0 or newer. Additionally, we recommend users to use RocketMQ ACL 2.0 instead of the original RocketMQ ACL when upgrading to version Apache RocketMQ 5.3.0.",
"evidence": "osv:CVE-2024-23321",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2024-23321",
"aliases": [
"CVE-2024-23321",
"GHSA-q9w2-h4cw-8ghp"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/rocketmq",
"type": "GIT",
"events": [
{
"introduced": "d63678dc507e5d341a125f95a99859d2fdafa408"
},
{
"fixed": "7ee50ec32e10265c45e00df5971dd78b9598ff6e"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:rocketmq:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "4.5.2"
},
{
"fixed": "5.3.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"rocketmq-all-5.2.0",
"rocketmq-all-5.1.4",
"rocketmq-all-5.1.3",
"rocketmq-all-5.1.2",
"rocketmq-all-5.1.1",
"rocketmq-all-5.1.0",
"rocketmq-all-4.9.4",
"rocketmq-all-4.9.3",
"rocketmq-all-4.9.2",
"rocketmq-all-4.9.1",
"rocketmq-all-4.9.0",
"rocketmq-all-4.8.0",
"rocketmq-all-4.7.1",
"rocketmq-all-4.7.0",
"rocketmq-all-4.6.0",
"rocketmq-all-4.6.1",
"rocketmq-all-4.5.2"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-23321.json"
}
}
],
"modified": "2026-10-28T02:30:35.844786099Z",
"provider": "osv",
"references": [
"https://repo.maven.apache.org/maven2",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/23xxx/CVE-2024-23321.json",
"https://lists.apache.org/thread/lr8npobww786nrnddd1pcy974r17c830",
"https://nvd.nist.gov/vuln/detail/CVE-2024-23321"
],
"provider_metadata": {
"cwe_ids": [
"CWE-200"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "4.5.2"
},
{
"last_affected": "5.2.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/23xxx/CVE-2024-23321.json"
}
},
"related_cves": [
{
"value": "CVE-2024-23321",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 503422,
"published_at": "2024-07-22T09:24:15.807+00:00"
}