Skip to content
Heist/ feed
Back to feed
HighFix available

mako — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2022-40023

Sqlalchemy mako before 1.2.2 is vulnerable to Regular expression Denial of Service when using the Lexer class to parse. This also affects babelplugin and linguaplugin.

Products
mako
Affected versions
Not specified
Fixed versions
1.2.2+ds1-1
CVEs
CVE-2022-40023
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 14:58 UTC · Revision 1

Source evidence

DEBIAN-CVE-2022-40023

core-osv · Original source

Published 7 Sept 2022, 13:15 UTC

Sqlalchemy mako before 1.2.2 is vulnerable to Regular expression Denial of Service when using the Lexer class to parse. This also affects babelplugin and linguaplugin.

osv:DEBIAN-CVE-2022-40023

mako

Fixed versions: 1.2.2+ds1-1

mako

Fixed versions: 1.2.2+ds1-1

mako

Fixed versions: 1.2.2+ds1-1

Complete source record
{
  "id": "0dac517d1c6cbbda8f65526c88cb2ddce7b8626e286fb344fe58af51179b0f5f",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-40023",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2022-40023",
    "summary": "Sqlalchemy mako before 1.2.2 is vulnerable to Regular expression Denial of Service when using the Lexer class to parse. This also affects babelplugin and linguaplugin.",
    "evidence": "osv:DEBIAN-CVE-2022-40023",
    "products": [
      {
        "name": {
          "value": "mako",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.2.2+ds1-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "mako",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.2.2+ds1-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "mako",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.2.2+ds1-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "DEBIAN-CVE-2022-40023",
      "aliases": [
        "DEBIAN-CVE-2022-40023"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.2.2+ds1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "mako",
            "purl": "pkg:deb/debian/mako?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-40023.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.2.2+ds1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "mako",
            "purl": "pkg:deb/debian/mako?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-40023.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.2.2+ds1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "mako",
            "purl": "pkg:deb/debian/mako?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-40023.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-15T08:02:41.277002589Z",
      "provider": "osv",
      "upstream": [
        "CVE-2022-40023"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2022-40023"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2022-40023",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 323972,
  "published_at": "2022-09-07T13:15:09.953+00:00"
}