strongswan — security advisory
strongSwan before 5.9.8 allows remote attackers to cause a denial of service in the revocation plugin by sending a crafted end-entity (and intermediate CA) certificate that contains a CRL/OCSP URL that points to a server (under the attacker's control) that doesn't properly respond but (for example) just does nothing after the initial TCP handshake, or sends an excessive amount of application data.
- Products
- strongswan
- Affected versions
- Not specified
- Fixed versions
- 5.9.8-1
- CVEs
- CVE-2022-40617
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 15:21 UTC · Revision 1
Source evidence
strongSwan before 5.9.8 allows remote attackers to cause a denial of service in the revocation plugin by sending a crafted end-entity (and intermediate CA) certificate that contains a CRL/OCSP URL that points to a server (under the attacker's control) that doesn't properly respond but (for example) just does nothing after the initial TCP handshake, or sends an excessive amount of application data.
osv:DEBIAN-CVE-2022-40617
strongswan
Fixed versions: 5.9.8-1
strongswan
Fixed versions: 5.9.8-1
strongswan
Fixed versions: 5.9.8-1
Complete source record
{
"id": "48f003e5d69ca336ecaf54fb30154f4d25977729d7ed1eb7415ec05256934030",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-40617",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-40617",
"summary": "strongSwan before 5.9.8 allows remote attackers to cause a denial of service in the revocation plugin by sending a crafted end-entity (and intermediate CA) certificate that contains a CRL/OCSP URL that points to a server (under the attacker's control) that doesn't properly respond but (for example) just does nothing after the initial TCP handshake, or sends an excessive amount of application data.",
"evidence": "osv:DEBIAN-CVE-2022-40617",
"products": [
{
"name": {
"value": "strongswan",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.9.8-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "strongswan",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.9.8-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "strongswan",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.9.8-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-40617",
"aliases": [
"DEBIAN-CVE-2022-40617"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.9.8-1"
}
]
}
],
"package": {
"name": "strongswan",
"purl": "pkg:deb/debian/strongswan?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-40617.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.9.8-1"
}
]
}
],
"package": {
"name": "strongswan",
"purl": "pkg:deb/debian/strongswan?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-40617.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.9.8-1"
}
]
}
],
"package": {
"name": "strongswan",
"purl": "pkg:deb/debian/strongswan?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-40617.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:53.905753525Z",
"provider": "osv",
"upstream": [
"CVE-2022-40617"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-40617"
]
},
"related_cves": [
{
"value": "CVE-2022-40617",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 324527,
"published_at": "2022-10-31T06:15:09.887+00:00"
}