tomcat-native — security advisory
Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a DoS via a JVM crash. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier, unsupported versions may also be affected. Users are recommended to upgrade to version 1.3.9 or 2.0.16, which fix the issue.
- Products
- tomcat-native
- Affected versions
- 1.2.35-1, 1.3.1-1, 1.3.7-1, 2.0.14-1, 2.0.16-1
- Fixed versions
- 2.0.16-1
- CVEs
- CVE-2026-86243
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 03:40 UTC · Revision 1
Source evidence
Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a DoS via a JVM crash. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier, unsupported versions may also be affected. Users are recommended to upgrade to version 1.3.9 or 2.0.16, which fix the issue.
osv:DEBIAN-CVE-2026-86243
tomcat-native
Fixed versions: Not specified
tomcat-native
Fixed versions: Not specified
tomcat-native
Fixed versions: 2.0.16-1
Complete source record
{
"id": "dbe6304dde1d23cce5d60449d6cc13643847a143f59092e2d919f68840eddc17",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-86243",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-86243",
"summary": "Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a DoS via a JVM crash. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier, unsupported versions may also be affected. Users are recommended to upgrade to version 1.3.9 or 2.0.16, which fix the issue.",
"evidence": "osv:DEBIAN-CVE-2026-86243",
"products": [
{
"name": {
"value": "tomcat-native",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1.2.35-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.3.1-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.3.7-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.0.14-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.0.16-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "tomcat-native",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1.3.1-1",
"evidence": "/affected/1/versions"
},
{
"value": "1.3.7-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.0.14-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.0.16-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "tomcat-native",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.0.16-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "1.3.1-1",
"evidence": "/affected/2/versions"
},
{
"value": "1.3.7-1",
"evidence": "/affected/2/versions"
},
{
"value": "2.0.14-1",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2026-86243",
"aliases": [
"DEBIAN-CVE-2026-86243"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "tomcat-native",
"purl": "pkg:deb/debian/tomcat-native?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"1.2.35-1",
"1.3.1-1",
"1.3.7-1",
"2.0.14-1",
"2.0.16-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-86243.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "tomcat-native",
"purl": "pkg:deb/debian/tomcat-native?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"1.3.1-1",
"1.3.7-1",
"2.0.14-1",
"2.0.16-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-86243.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.16-1"
}
]
}
],
"package": {
"name": "tomcat-native",
"purl": "pkg:deb/debian/tomcat-native?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"1.3.1-1",
"1.3.7-1",
"2.0.14-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-86243.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-07T09:47:27.983431358Z",
"provider": "osv",
"upstream": [
"CVE-2026-86243"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-86243"
]
},
"related_cves": [
{
"value": "CVE-2026-86243",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 94642,
"published_at": "2026-09-23T13:17:30.993+00:00"
}