UnratedFix available
wordpress — security advisory
SQL injection vulnerability in wp-includes/query.php in WordPress 2.3.1 and earlier allows remote attackers to execute arbitrary SQL commands via the s parameter, when DB_CHARSET is set to (1) Big5, (2) GBK, or possibly other character set encodings that support a "\" in a multibyte character.
- Products
- wordpress
- Affected versions
- Not specified
- Fixed versions
- 2.3.2-1
- CVEs
- CVE-2007-6318
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 15:45 UTC · Revision 1
Source evidence
SQL injection vulnerability in wp-includes/query.php in WordPress 2.3.1 and earlier allows remote attackers to execute arbitrary SQL commands via the s parameter, when DB_CHARSET is set to (1) Big5, (2) GBK, or possibly other character set encodings that support a "\" in a multibyte character.
osv:DEBIAN-CVE-2007-6318
wordpress
Fixed versions: 2.3.2-1
wordpress
Fixed versions: 2.3.2-1
wordpress
Fixed versions: 2.3.2-1
Complete source record
{
"id": "51e2d1f2fed647c8559c2391c6de95d58adc635711d5aa1795f7bccc9e9bfed3",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2007-6318",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2007-6318",
"summary": "SQL injection vulnerability in wp-includes/query.php in WordPress 2.3.1 and earlier allows remote attackers to execute arbitrary SQL commands via the s parameter, when DB_CHARSET is set to (1) Big5, (2) GBK, or possibly other character set encodings that support a \"\\\" in a multibyte character.",
"evidence": "osv:DEBIAN-CVE-2007-6318",
"products": [
{
"name": {
"value": "wordpress",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.3.2-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "wordpress",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.3.2-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "wordpress",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.3.2-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2007-6318",
"aliases": [
"DEBIAN-CVE-2007-6318"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.3.2-1"
}
]
}
],
"package": {
"name": "wordpress",
"purl": "pkg:deb/debian/wordpress?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2007-6318.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.3.2-1"
}
]
}
],
"package": {
"name": "wordpress",
"purl": "pkg:deb/debian/wordpress?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2007-6318.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.3.2-1"
}
]
}
],
"package": {
"name": "wordpress",
"purl": "pkg:deb/debian/wordpress?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2007-6318.json"
},
"ecosystem_specific": {
"urgency": "low"
}
}
],
"modified": "2026-10-21T17:47:33.874483532Z",
"provider": "osv",
"upstream": [
"CVE-2007-6318"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2007-6318"
]
},
"related_cves": [
{
"value": "CVE-2007-6318",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 398296,
"published_at": "2007-12-12T00:46:00+00:00"
}