Skip to content
Heist/ feed
Back to feed
High

@arikusi/deepseek-mcp-server has an Authorization Bypass Through User-Controlled Key

Type: advisorySources: OSV

DeepSeek MCP Server is an MCP server for DeepSeek V4. Starting in version 1.4.2 and prior to version 1.7.0, the process-global `SessionStore` accepts caller-supplied `session_id` values without binding them to any authenticated principal or transport session. An attacker can enumerate active session IDs via `deepseek_sessions`, then reuse a victim-controlled `session_id` in `deepseek_chat` to retrieve and continue the victim's conversation context. Version 1.7.0 contains a patch.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-55604
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 13:38 UTC · Revision 1

Source evidence

@arikusi/deepseek-mcp-server has an Authorization Bypass Through User-Controlled Key

core-osv · Original source

Published 9 Jul 2026, 21:13 UTC

DeepSeek MCP Server is an MCP server for DeepSeek V4. Starting in version 1.4.2 and prior to version 1.7.0, the process-global `SessionStore` accepts caller-supplied `session_id` values without binding them to any authenticated principal or transport session. An attacker can enumerate active session IDs via `deepseek_sessions`, then reuse a victim-controlled `session_id` in `deepseek_chat` to retrieve and continue the victim's conversation context. Version 1.7.0 contains a patch.

osv:CVE-2026-55604
Complete source record
{
  "id": "d0edc85f8c4bbf10469360b79134330885efc60ef00ca55f0b7cdb7307aa4258",
  "url": "https://osv.dev/vulnerability/CVE-2026-55604",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "@arikusi/deepseek-mcp-server has an Authorization Bypass Through User-Controlled Key",
    "summary": "DeepSeek MCP Server is an MCP server for DeepSeek V4. Starting in version 1.4.2 and prior to version 1.7.0, the process-global `SessionStore` accepts caller-supplied `session_id` values without binding them to any authenticated principal or transport session. An attacker can enumerate active session IDs via `deepseek_sessions`, then reuse a victim-controlled `session_id` in `deepseek_chat` to retrieve and continue the victim's conversation context. Version 1.7.0 contains a patch.",
    "evidence": "osv:CVE-2026-55604",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2026-55604",
      "aliases": [
        "CVE-2026-55604",
        "GHSA-fh3r-g96v-f578"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/arikusi/deepseek-mcp-server",
              "type": "GIT",
              "events": [
                {
                  "introduced": "1f90faae26935a7c16efaaf7e8251d551efae2c0"
                },
                {
                  "fixed": "9fd514292d23d59ca1434b01f019aca6ef4356f9"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "1.4.2"
                      },
                      {
                        "fixed": "1.7.0"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "fixed": "9fd514292d23d59ca1434b01f019aca6ef4356f9"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v1.7.0"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v1.6.0",
            "v1.5.2",
            "v1.5.1",
            "v1.5.0",
            "v1.4.3",
            "v1.4.2"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-55604.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:50.785046365Z",
      "provider": "osv",
      "references": [
        "https://github.com/arikusi/deepseek-mcp-server/releases/tag/v1.7.0",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/55xxx/CVE-2026-55604.json",
        "https://github.com/arikusi/deepseek-mcp-server/security/advisories/GHSA-fh3r-g96v-f578",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-55604"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-639"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/55xxx/CVE-2026-55604.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-55604",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 519489,
  "published_at": "2026-07-09T21:13:15.713+00:00"
}