Skip to content
Heist/ feed
Back to feed
Low

CloudPanel Community Edition HTTP Header users redirect

Type: advisorySources: OSV

A security vulnerability has been detected in CloudPanel Community Edition up to 2.5.1. The affected element is an unknown function of the file /admin/users of the component HTTP Header Handler. Such manipulation of the argument Referer leads to open redirect. It is possible to launch the attack remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 2.5.2 is sufficient to fix this issue. Upgrading the affected component is recommended.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-15241
Confirmed fixed CVEs
Not specified
Updated in this feed
2 Nov 2026, 20:58 UTC · Revision 1

Source evidence

CloudPanel Community Edition HTTP Header users redirect

core-osv · Original source

Published 30 Dec 2025, 09:02 UTC

A security vulnerability has been detected in CloudPanel Community Edition up to 2.5.1. The affected element is an unknown function of the file /admin/users of the component HTTP Header Handler. Such manipulation of the argument Referer leads to open redirect. It is possible to launch the attack remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 2.5.2 is sufficient to fix this issue. Upgrading the affected component is recommended.

osv:CVE-2025-15241
Complete source record
{
  "id": "783bd33175b4d4ee6533b94e5528523c36c720b4287230997abadbb67bb65053",
  "url": "https://osv.dev/vulnerability/CVE-2025-15241",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CloudPanel Community Edition HTTP Header users redirect",
    "summary": "A security vulnerability has been detected in CloudPanel Community Edition up to 2.5.1. The affected element is an unknown function of the file /admin/users of the component HTTP Header Handler. Such manipulation of the argument Referer leads to open redirect. It is possible to launch the attack remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 2.5.2 is sufficient to fix this issue. Upgrading the affected component is recommended.",
    "evidence": "osv:CVE-2025-15241",
    "products": [],
    "severity": "low",
    "structured": {
      "id": "CVE-2025-15241",
      "aliases": [
        "CVE-2025-15241"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/cloudpanel-io/cloudpanel-ce",
              "type": "GIT",
              "events": [
                {
                  "introduced": "d7834938da11d0c25c157275414118606046d22e"
                },
                {
                  "fixed": "4578c74711bc8874e14caa5615169e6e4cd0ceae"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "2.5.0"
                      },
                      {
                        "last_affected": "2.5.0"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StandaloneSingleVersion"
                  },
                  {
                    "range": [
                      {
                        "introduced": "2.5.1"
                      },
                      {
                        "last_affected": "2.5.1"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StandaloneSingleVersion"
                  },
                  {
                    "range": [
                      {
                        "fixed": "4578c74711bc8874e14caa5615169e6e4cd0ceae"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v2.5.2"
                  }
                ]
              }
            }
          ],
          "versions": [
            "2.5.0",
            "2.5.1",
            "v2.5.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-15241.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:23.564622020Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/15xxx/CVE-2025-15241.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-15241",
        "https://vuldb.com/?id.338631",
        "https://vuldb.com/?submit.725543",
        "https://vuldb.com/?ctiid.338631",
        "https://github.com/cloudpanel-io/cloudpanel-ce/releases/tag/v2.5.2",
        "https://github.com/Stolichnayer/cloudpanel-open-redirect",
        "https://github.com/Stolichnayer/cloudpanel-open-redirect?tab=readme-ov-file#%EF%B8%8F-steps-to-reproduce"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-601"
        ],
        "cna_assigner": "VulDB",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/15xxx/CVE-2025-15241.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-15241",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 490031,
  "published_at": "2025-12-30T09:02:07.225+00:00"
}