undici vulnerable to Denial of Service via unbounded memory in the EventSource parser
undici is an HTTP client library for Node.js. In versions 6.5.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its EventSource client can be driven to exhaust process memory by a malicious or compromised Server-Sent Events peer. By sending millions of tiny completed data fields with no blank event separator, or a single unfinished line split across many chunks, the parser retains a growing amount of per-field and per-chunk state that the byte-based maxEventSize and maxResponseSize limits do not bound, and because maxResponseSize is enforced on the compressed body before decompression, a small compressed response can expand into enough retained memory to terminate the process. An application only needs to maintain an EventSource connection to an untrusted peer, which controls only the response, and availability is the only impact. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, which bound the retained parser state independently of the byte limits, and users should upgrade to one of those versions or later. There is no workaround.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-109924
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 17:14 UTC · Revision 1
Source evidence
undici vulnerable to Denial of Service via unbounded memory in the EventSource parser
core-osv · Original sourcePublished 15 Oct 2026, 18:16 UTC
undici is an HTTP client library for Node.js. In versions 6.5.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its EventSource client can be driven to exhaust process memory by a malicious or compromised Server-Sent Events peer. By sending millions of tiny completed data fields with no blank event separator, or a single unfinished line split across many chunks, the parser retains a growing amount of per-field and per-chunk state that the byte-based maxEventSize and maxResponseSize limits do not bound, and because maxResponseSize is enforced on the compressed body before decompression, a small compressed response can expand into enough retained memory to terminate the process. An application only needs to maintain an EventSource connection to an untrusted peer, which controls only the response, and availability is the only impact. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, which bound the retained parser state independently of the byte limits, and users should upgrade to one of those versions or later. There is no workaround.
osv:CVE-2026-109924
Complete source record
{
"id": "70d031bf1eba45408043fa843b9fd0f8c546788226ab7226db419acde4d2f30b",
"url": "https://osv.dev/vulnerability/CVE-2026-109924",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "undici vulnerable to Denial of Service via unbounded memory in the EventSource parser",
"summary": "undici is an HTTP client library for Node.js. In versions 6.5.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its EventSource client can be driven to exhaust process memory by a malicious or compromised Server-Sent Events peer. By sending millions of tiny completed data fields with no blank event separator, or a single unfinished line split across many chunks, the parser retains a growing amount of per-field and per-chunk state that the byte-based maxEventSize and maxResponseSize limits do not bound, and because maxResponseSize is enforced on the compressed body before decompression, a small compressed response can expand into enough retained memory to terminate the process. An application only needs to maintain an EventSource connection to an untrusted peer, which controls only the response, and availability is the only impact. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, which bound the retained parser state independently of the byte limits, and users should upgrade to one of those versions or later. There is no workaround.",
"evidence": "osv:CVE-2026-109924",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2026-109924",
"aliases": [
"CVE-2026-109924",
"GHSA-4qv8-2p9j-2685"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/nodejs/undici",
"type": "GIT",
"events": [
{
"introduced": "519b9e13543a594bcfa4d1954bf639c10cf3e824"
},
{
"fixed": "8c57f6c68c95465338ae97bfc991cb1513d2f76e"
},
{
"introduced": "1cfe0949053aac6267f11b919cee9315a27f1fd6"
},
{
"fixed": "7507102a675b082a71437f0a00681e537875556c"
},
{
"introduced": "d7fbba51772deecb830a297647456a5e9f9fec57"
},
{
"fixed": "bb6cc0ae9b6827ed273ed5ba344148273629638f"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:nodejs:undici:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "6.5.0"
},
{
"fixed": "6.29.1"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:nodejs:undici:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "7.0.0"
},
{
"fixed": "7.30.1"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:nodejs:undici:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "8.0.0"
},
{
"fixed": "8.12.2"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v8.12.1",
"v8.12.0",
"v6.29.0",
"v7.30.0",
"v8.11.2",
"v8.11.1",
"v8.11.0",
"v6.28.1",
"v7.29.1",
"v8.10.2",
"v8.10.1",
"v8.10.0",
"v6.28.0",
"v8.9.0",
"v7.29.0",
"v6.27.0",
"v7.28.0",
"v8.8.0",
"v8.7.0",
"v8.6.0",
"v8.5.0",
"v6.26.0",
"v7.27.2",
"v8.4.1",
"v8.4.0",
"v7.27.1",
"v7.27.0",
"v7.26.0",
"v6.25.0",
"v8.3.0",
"v8.2.0",
"v7.25.0",
"v7.24.8",
"v8.1.0",
"v8.0.3",
"v8.0.2",
"v8.0.1",
"v8.0.0",
"v7.24.7",
"v7.24.6",
"v7.24.5",
"v7.24.4",
"v7.24.3",
"v7.24.2",
"v6.24.1",
"v6.24.0",
"v7.24.1",
"v7.24.0",
"v6.23.0",
"v7.23.0",
"v7.22.0",
"v7.21.0",
"v7.20.0",
"v7.19.2",
"v7.19.1",
"v7.19.0",
"v7.18.2",
"v7.18.1",
"v7.18.0",
"v6.22.0",
"v7.17.0",
"v7.16.0",
"v7.15.0",
"v6.21.3",
"v7.14.0",
"v7.13.0",
"v7.12.0",
"v7.11.0",
"v7.10.0",
"v6.21.2",
"v7.9.0",
"v7.8.0",
"v7.7.0",
"v7.5.0",
"v7.6.0",
"v7.4.0",
"v6.21.1",
"v7.3.0",
"v7.2.3",
"v7.2.2",
"v7.2.1",
"v7.2.0",
"v7.1.1",
"v7.1.0",
"v7.0.0",
"v6.21.0",
"v6.20.1",
"v6.20.0",
"v6.19.8",
"v6.19.7",
"v6.19.6",
"v6.19.5",
"v6.19.4",
"v6.19.3",
"v6.19.2",
"v6.19.1",
"v6.19.0",
"v6.18.2",
"v6.18.1",
"v6.18.0",
"v6.17.0",
"v6.16.1",
"v6.16.0",
"v6.15.0",
"v6.14.1",
"v6.14.0",
"v6.13.0",
"v6.12.0",
"v6.11.1",
"v6.11.0",
"v6.10.2",
"v6.10.1",
"v6.10.0",
"v6.9.0",
"v6.8.0",
"v6.7.1",
"v6.7.0",
"v6.6.2",
"v6.6.1",
"v6.6.0",
"v6.5.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-109924.json"
}
}
],
"modified": "2026-10-28T02:30:30.599175127Z",
"provider": "osv",
"references": [
"https://cna.openjsf.org/security-advisories.html",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/109xxx/CVE-2026-109924.json",
"https://github.com/nodejs/undici/security/advisories/GHSA-4qv8-2p9j-2685",
"https://nvd.nist.gov/vuln/detail/CVE-2026-109924"
],
"provider_metadata": {
"cwe_ids": [
"CWE-770"
],
"cna_assigner": "openjs",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/109xxx/CVE-2026-109924.json"
}
},
"related_cves": [
{
"value": "CVE-2026-109924",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 497744,
"published_at": "2026-10-15T18:16:48.452+00:00"
}