Medium
Apache Camel Neo4j: Cypher injection vulnerability in Camel-Neo4j component
Type: advisorySources: OSV
Cypher Injection vulnerability in Apache Camel camel-neo4j component. This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.3, from 4.15.0 before 4.17.0 Users are recommended to upgrade to version 4.10.8 for 4.10.x LTS and 4.14.3 for 4.14.x LTS and 4.17.0.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-66169
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 16:45 UTC · Revision 1
Source evidence
Apache Camel Neo4j: Cypher injection vulnerability in Camel-Neo4j component
core-osv · Original sourcePublished 14 Jan 2026, 11:45 UTC
Cypher Injection vulnerability in Apache Camel camel-neo4j component. This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.3, from 4.15.0 before 4.17.0 Users are recommended to upgrade to version 4.10.8 for 4.10.x LTS and 4.14.3 for 4.14.x LTS and 4.17.0.
osv:CVE-2025-66169
Complete source record
{
"id": "5d86777d6a38522eafd0987e532843967ae584a2770c3b734fcb52a3be1fdec5",
"url": "https://osv.dev/vulnerability/CVE-2025-66169",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache Camel Neo4j: Cypher injection vulnerability in Camel-Neo4j component",
"summary": "Cypher Injection vulnerability in Apache Camel camel-neo4j component. This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.3, from 4.15.0 before 4.17.0 Users are recommended to upgrade to version 4.10.8 for 4.10.x LTS and 4.14.3 for 4.14.x LTS and 4.17.0.",
"evidence": "osv:CVE-2025-66169",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-66169",
"aliases": [
"CVE-2025-66169",
"GHSA-4jrw-64vr-7g8m"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/camel",
"type": "GIT",
"events": [
{
"introduced": "6f00e4749db83b2f8b797b79e7cf9c4ace314ba9"
},
{
"fixed": "6a9955c07da4cc92988a4c6af8778e5069cdb255"
},
{
"introduced": "669dd75eeffe052dcfc9f3f94369e501d275daf4"
},
{
"fixed": "bfd8046a853854fbe753939a30aec8b5452bc61d"
},
{
"introduced": "038f1b2acd0b2ee78e4bb84cd3139e64610bb259"
},
{
"fixed": "7a20d8f4445e66173c78d56c2bdbeeddbb14cbfc"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "4.10.0"
},
{
"fixed": "4.10.8"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "4.14.0"
},
{
"fixed": "4.14.3"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "4.15.0"
},
{
"fixed": "4.17.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-66169.json"
}
}
],
"modified": "2026-10-28T02:30:37.410656360Z",
"provider": "osv",
"references": [
"https://repo.maven.apache.org/maven2",
"https://camel.apache.org/security/CVE-2025-66169.html",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/66xxx/CVE-2025-66169.json",
"https://nvd.nist.gov/vuln/detail/CVE-2025-66169"
],
"provider_metadata": {
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "4.10.0"
},
{
"fixed": "4.10.8"
},
{
"introduced": "4.14.0"
},
{
"fixed": "4.14.3"
},
{
"introduced": "4.15.0"
},
{
"fixed": "4.17.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/66xxx/CVE-2025-66169.json"
}
},
"related_cves": [
{
"value": "CVE-2025-66169",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 504879,
"published_at": "2026-01-14T11:45:20.338+00:00"
}