Skip to content
Heist/ feed
Back to feed
Critical

Security advisory

Type: advisorySources: OSVCVE: CVE-2019-25098

A vulnerability was found in soerennb eXtplorer up to 2.1.12. It has been classified as critical. This affects an unknown part of the file include/archive.php of the component Archive Handler. The manipulation leads to path traversal. Upgrading to version 2.1.13 is able to address this issue. The identifier of the patch is b8fcb888f4ff5e171c16797a4b075c6c6f50bf46. It is recommended to upgrade the affected component. The identifier VDB-217437 was assigned to this vulnerability.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2019-25098
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 11:03 UTC · Revision 1

Source evidence

CVE-2019-25098

core-osv · Original source

Published 5 Jan 2023, 08:15 UTC

A vulnerability was found in soerennb eXtplorer up to 2.1.12. It has been classified as critical. This affects an unknown part of the file include/archive.php of the component Archive Handler. The manipulation leads to path traversal. Upgrading to version 2.1.13 is able to address this issue. The identifier of the patch is b8fcb888f4ff5e171c16797a4b075c6c6f50bf46. It is recommended to upgrade the affected component. The identifier VDB-217437 was assigned to this vulnerability.

osv:CVE-2019-25098
Complete source record
{
  "id": "dfbb6394f948ed7505722879b1e989464c1e0b6e2bac02a6d76285e253bb0f80",
  "url": "https://osv.dev/vulnerability/CVE-2019-25098",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2019-25098",
    "summary": "A vulnerability was found in soerennb eXtplorer up to 2.1.12. It has been classified as critical. This affects an unknown part of the file include/archive.php of the component Archive Handler. The manipulation leads to path traversal. Upgrading to version 2.1.13 is able to address this issue. The identifier of the patch is b8fcb888f4ff5e171c16797a4b075c6c6f50bf46. It is recommended to upgrade the affected component. The identifier VDB-217437 was assigned to this vulnerability.",
    "evidence": "osv:CVE-2019-25098",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2019-25098",
      "aliases": [
        "CVE-2019-25098"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/soerennb/extplorer",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "b8fcb888f4ff5e171c16797a4b075c6c6f50bf46"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:extplorer:extplorer:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.1.13"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "b8fcb888f4ff5e171c16797a4b075c6c6f50bf46"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "range": [
                      {
                        "fixed": "b8fcb888f4ff5e171c16797a4b075c6c6f50bf46"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v2.1.13"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v2.1.11"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-25098.json"
          }
        }
      ],
      "modified": "2026-10-20T10:52:42.285327678Z",
      "provider": "osv",
      "references": [
        "https://github.com/soerennb/extplorer/releases/tag/v2.1.13",
        "https://vuldb.com/?ctiid.217437",
        "https://vuldb.com/?id.217437",
        "https://github.com/soerennb/extplorer/commit/b8fcb888f4ff5e171c16797a4b075c6c6f50bf46"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2019-25098",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 383749,
  "published_at": "2023-01-05T08:15:08.673+00:00"
}