Skip to content
Heist/ feed
Back to feed
Medium

Cacti is vulnerable to cross-Site scripting (XSS) DOM

Type: advisorySources: OSV

Cacti is a robust performance and fault management framework and a frontend to RRDTool - a Time Series Database (TSDB). A vulnerability in versions prior to 1.2.27 bypasses an earlier fix for CVE-2023-39360, therefore leading to a DOM XSS attack. Exploitation of the vulnerability is possible for an authorized user. The vulnerable component is the `graphs_new.php`. The impact of the vulnerability is execution of arbitrary JavaScript code in the attacked user's browser. This issue has been patched in version 1.2.27.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2023-49086
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 16:44 UTC · Revision 1

Source evidence

Cacti is vulnerable to cross-Site scripting (XSS) DOM

core-osv · Original source

Published 21 Dec 2023, 23:29 UTC

Cacti is a robust performance and fault management framework and a frontend to RRDTool - a Time Series Database (TSDB). A vulnerability in versions prior to 1.2.27 bypasses an earlier fix for CVE-2023-39360, therefore leading to a DOM XSS attack. Exploitation of the vulnerability is possible for an authorized user. The vulnerable component is the `graphs_new.php`. The impact of the vulnerability is execution of arbitrary JavaScript code in the attacked user's browser. This issue has been patched in version 1.2.27.

osv:CVE-2023-49086
Complete source record
{
  "id": "338d6ac1e61e79145db9fa604e3cca86498458acd9c5c20f6982961a81214fcf",
  "url": "https://osv.dev/vulnerability/CVE-2023-49086",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Cacti is vulnerable to cross-Site scripting (XSS) DOM",
    "summary": "Cacti is a robust performance and fault management framework and a frontend to RRDTool - a Time Series Database (TSDB). A vulnerability in versions prior to 1.2.27 bypasses an earlier fix for CVE-2023-39360, therefore leading to a DOM XSS attack. Exploitation of the vulnerability is possible for an authorized user. The vulnerable component is the `graphs_new.php`. The impact of the vulnerability is execution of arbitrary JavaScript code in the attacked user's browser. This issue has been patched in version 1.2.27.",
    "evidence": "osv:CVE-2023-49086",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2023-49086",
      "aliases": [
        "CVE-2023-49086",
        "GHSA-wc73-r2vw-59pr"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/cacti/cacti",
              "type": "GIT",
              "events": [
                {
                  "introduced": "18500fa313a9f1ee1be48aa111c0eeea001010fa"
                },
                {
                  "fixed": "6ec01c8b2983bf4fcb86f8c647655f74090b5be9"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:cacti:cacti:1.2.25:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "1.2.25"
                      },
                      {
                        "last_affected": "1.2.25"
                      }
                    ],
                    "source": "CPE_STRING"
                  },
                  {
                    "range": [
                      {
                        "fixed": "6ec01c8b2983bf4fcb86f8c647655f74090b5be9"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "1.2.25"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-49086.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:30.559918469Z",
      "provider": "osv",
      "references": [
        "https://lists.debian.org/debian-lts-announce/2024/03/msg00018.html",
        "https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RBEOAFKRARQHTDIYSL723XAFJ2Q6624X/",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/49xxx/CVE-2023-49086.json",
        "https://github.com/Cacti/cacti/security/advisories/GHSA-wc73-r2vw-59pr",
        "https://nvd.nist.gov/vuln/detail/CVE-2023-49086",
        "https://github.com/Cacti/cacti/commit/6ec01c8b2983bf4fcb86f8c647655f74090b5be9"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/49xxx/CVE-2023-49086.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2023-49086",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 497524,
  "published_at": "2023-12-21T23:29:45.134+00:00"
}