Discourse has DoS vulnerability in username change endpoint
Discourse is an open source discussion platform. Versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 have an application level denial of service vulnerabilityin the username change functionality at try.discourse.org. The vulnerability allows attackers to cause noticeable server delays and resource exhaustion by sending large JSON payloads to the username preference endpoint PUT /u//preferences/username, resulting in degraded performance for other users and endpoints. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. No known workarounds are available.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-68659
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 6 Nov 2026, 02:12 UTC · Revision 1
Source evidence
Discourse has DoS vulnerability in username change endpoint
core-osv · Original sourcePublished 28 Jan 2026, 18:51 UTC
Discourse is an open source discussion platform. Versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 have an application level denial of service vulnerabilityin the username change functionality at try.discourse.org. The vulnerability allows attackers to cause noticeable server delays and resource exhaustion by sending large JSON payloads to the username preference endpoint PUT /u//preferences/username, resulting in degraded performance for other users and endpoints. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. No known workarounds are available.
osv:CVE-2025-68659
Complete source record
{
"id": "5241f22a524bbe2dd9398361de661e8ff4b936e3b521f8941e6624cfe23c99a6",
"url": "https://osv.dev/vulnerability/CVE-2025-68659",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Discourse has DoS vulnerability in username change endpoint",
"summary": "Discourse is an open source discussion platform. Versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 have an application level denial of service vulnerabilityin the username change functionality at try.discourse.org. The vulnerability allows attackers to cause noticeable server delays and resource exhaustion by sending large JSON payloads to the username preference endpoint PUT /u//preferences/username, resulting in degraded performance for other users and endpoints. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. No known workarounds are available.",
"evidence": "osv:CVE-2025-68659",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-68659",
"aliases": [
"BIT-discourse-2025-68659",
"CVE-2025-68659",
"GHSA-rmp6-c9rq-6q7p"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/discourse/discourse",
"type": "GIT",
"events": [
{
"introduced": "75d61b40ee928a4620b16f5438ca886678fab00d"
},
{
"fixed": "f31b18139a7aadbc4a5f7e8e565a6f4376010c3a"
},
{
"introduced": "3e7317b3344cca6c6510a32cc4c5c0f540132ad9"
},
{
"last_affected": "322d3c0ac6a8f133b3f82875e9dbbe310f638c1b"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:discourse:discourse:*:*:*:*:stable:*:*:*",
"range": [
{
"introduced": "2025.11.0"
},
{
"fixed": "2025.11.2"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:discourse:discourse:2025.12.0:*:*:*:stable:*:*:*",
"range": [
{
"introduced": "2025.12.0"
},
{
"last_affected": "2025.12.0"
}
],
"source": "CPE_STRING"
},
{
"cpe": "cpe:2.3:a:discourse:discourse:2026.1.0:*:*:*:stable:*:*:*",
"range": [
{
"introduced": "2026.1.0"
},
{
"last_affected": "2026.1.0"
}
],
"source": "CPE_STRING"
}
]
}
}
],
"versions": [
"2025.12.0",
"2026.1.0",
"v2025.11.1",
"v2026.1.0-latest",
"v2025.11.0",
"v2025.12.0-latest"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-68659.json"
}
}
],
"modified": "2026-10-28T02:30:45.952876516Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/68xxx/CVE-2025-68659.json",
"https://github.com/discourse/discourse/security/advisories/GHSA-rmp6-c9rq-6q7p",
"https://nvd.nist.gov/vuln/detail/CVE-2025-68659"
],
"provider_metadata": {
"cwe_ids": [
"CWE-770"
],
"cna_assigner": "GitHub_M",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "3.5.4"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/68xxx/CVE-2025-68659.json"
}
},
"related_cves": [
{
"value": "CVE-2025-68659",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 514174,
"published_at": "2026-01-28T18:51:40.341+00:00"
}