Skip to content
Heist/ feed
Back to feed
CriticalFix available

apache2 — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2022-23943

Out-of-bounds Write vulnerability in mod_sed of Apache HTTP Server allows an attacker to overwrite heap memory with possibly attacker provided data. This issue affects Apache HTTP Server 2.4 version 2.4.52 and prior versions.

Products
apache2
Affected versions
Not specified
Fixed versions
2.4.53-1
CVEs
CVE-2022-23943
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 14:36 UTC · Revision 1

Source evidence

DEBIAN-CVE-2022-23943

core-osv · Original source

Published 14 Mar 2022, 11:15 UTC

Out-of-bounds Write vulnerability in mod_sed of Apache HTTP Server allows an attacker to overwrite heap memory with possibly attacker provided data. This issue affects Apache HTTP Server 2.4 version 2.4.52 and prior versions.

osv:DEBIAN-CVE-2022-23943

apache2

Fixed versions: 2.4.53-1

apache2

Fixed versions: 2.4.53-1

apache2

Fixed versions: 2.4.53-1

Complete source record
{
  "id": "b2972311a28523565df0b2bb6bc0f468436b3192ff73d243b90fe0202ba750ea",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-23943",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2022-23943",
    "summary": "Out-of-bounds Write vulnerability in mod_sed of Apache HTTP Server allows an attacker to overwrite heap memory with possibly attacker provided data. This issue affects Apache HTTP Server 2.4 version 2.4.52 and prior versions.",
    "evidence": "osv:DEBIAN-CVE-2022-23943",
    "products": [
      {
        "name": {
          "value": "apache2",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.4.53-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "apache2",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.4.53-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "apache2",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.4.53-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "critical",
    "structured": {
      "id": "DEBIAN-CVE-2022-23943",
      "aliases": [
        "DEBIAN-CVE-2022-23943"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.4.53-1"
                }
              ]
            }
          ],
          "package": {
            "name": "apache2",
            "purl": "pkg:deb/debian/apache2?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23943.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.4.53-1"
                }
              ]
            }
          ],
          "package": {
            "name": "apache2",
            "purl": "pkg:deb/debian/apache2?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23943.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.4.53-1"
                }
              ]
            }
          ],
          "package": {
            "name": "apache2",
            "purl": "pkg:deb/debian/apache2?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23943.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-15T08:01:00.404952247Z",
      "provider": "osv",
      "upstream": [
        "CVE-2022-23943"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2022-23943"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2022-23943",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 322751,
  "published_at": "2022-03-14T11:15:09.187+00:00"
}