Skip to content
Heist/ feed
Back to feed
Low

Apache Subversion: mod_dav_svn denial-of-service via control characters in paths

Type: advisorySources: OSV

Insufficient validation of filenames against control characters in Apache Subversion repositories served via mod_dav_svn allows authenticated users with commit access to commit a corrupted revision, leading to disruption for users of the repository. All versions of Subversion up to and including Subversion 1.14.4 are affected if serving repositories via mod_dav_svn. Users are recommended to upgrade to version 1.14.5, which fixes this issue. Repositories served via other access methods are not affected.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-46901
Confirmed fixed CVEs
Not specified
Updated in this feed
8 Nov 2026, 02:36 UTC · Revision 1

Source evidence

Apache Subversion: mod_dav_svn denial-of-service via control characters in paths

core-osv · Original source

Published 9 Dec 2024, 09:36 UTC

Insufficient validation of filenames against control characters in Apache Subversion repositories served via mod_dav_svn allows authenticated users with commit access to commit a corrupted revision, leading to disruption for users of the repository. All versions of Subversion up to and including Subversion 1.14.4 are affected if serving repositories via mod_dav_svn. Users are recommended to upgrade to version 1.14.5, which fixes this issue. Repositories served via other access methods are not affected.

osv:CVE-2024-46901
Complete source record
{
  "id": "07188d0a08f85545ef1df19a234fc95d283213f6293d57bf79819c62358e8dc2",
  "url": "https://osv.dev/vulnerability/CVE-2024-46901",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache Subversion: mod_dav_svn denial-of-service via control characters in paths",
    "summary": "Insufficient validation of filenames against control characters in Apache Subversion repositories served via mod_dav_svn allows authenticated users with commit access to commit a corrupted revision, leading to disruption for users of the repository. All versions of Subversion up to and including Subversion 1.14.4 are affected if serving repositories via mod_dav_svn. Users are recommended to upgrade to version 1.14.5, which fixes this issue. Repositories served via other access methods are not affected.",
    "evidence": "osv:CVE-2024-46901",
    "products": [],
    "severity": "low",
    "structured": {
      "id": "CVE-2024-46901",
      "aliases": [
        "BIT-subversion-2024-46901",
        "CVE-2024-46901"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/subversion",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "c828a37af875249916a452481cae96df83dc67ea"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:subversion:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.14.5"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-46901.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:52.886766330Z",
      "provider": "osv",
      "references": [
        "https://lists.debian.org/debian-lts-announce/2025/04/msg00023.html",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/46xxx/CVE-2024-46901.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-46901",
        "https://subversion.apache.org/security/CVE-2024-46901-advisory.txt"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-116",
          "CWE-20"
        ],
        "cna_assigner": "apache",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "last_affected": "1.14.4"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/46xxx/CVE-2024-46901.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-46901",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 521842,
  "published_at": "2024-12-09T09:36:52.445+00:00"
}