Apache APISIX: Openid-connect introspection validation issue
Improper Authentication vulnerability in Apache APISIX. On a route using openid-connect plugin with remote introspection against an authorization server that serves multiple issuers, a token that introspects as active for one issuer may get accepted on a route restricted to another. This issue affects Apache APISIX: from 3.12.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.
- Products
- apisix
- Affected versions
- Not specified
- Fixed versions
- 3.19.0
- CVEs
- CVE-2026-94276
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 12:32 UTC · Revision 1
Source evidence
Apache APISIX: Openid-connect introspection validation issue
core-osv · Original sourcePublished 9 Oct 2026, 10:43 UTC
Improper Authentication vulnerability in Apache APISIX. On a route using openid-connect plugin with remote introspection against an authorization server that serves multiple issuers, a token that introspects as active for one issuer may get accepted on a route restricted to another. This issue affects Apache APISIX: from 3.12.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.
osv:BIT-apisix-2026-94276
apisix
Fixed versions: 3.19.0
Complete source record
{
"id": "9dcd6859f8ae3cb751312c175b2bf17222d86acdf8a3126cf47ce33cfea77ee1",
"url": "https://osv.dev/vulnerability/BIT-apisix-2026-94276",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache APISIX: Openid-connect introspection validation issue",
"summary": "Improper Authentication vulnerability in Apache APISIX. On a route using openid-connect plugin with remote introspection against an authorization server that serves multiple issuers, a token that introspects as active for one issuer may get accepted on a route restricted to another. This issue affects Apache APISIX: from 3.12.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.",
"evidence": "osv:BIT-apisix-2026-94276",
"products": [
{
"name": {
"value": "apisix",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.19.0",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "BIT-apisix-2026-94276",
"aliases": [
"BIT-apisix-2026-94276",
"CVE-2026-94276"
],
"affected": [
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "3.12.0"
},
{
"fixed": "3.19.0"
}
]
}
],
"package": {
"name": "apisix",
"purl": "pkg:bitnami/apisix",
"ecosystem": "Bitnami"
},
"severity": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X"
}
],
"database_specific": {
"source": "https://github.com/bitnami/vulndb/tree/main/data/apisix/BIT-apisix-2026-94276.json"
}
}
],
"modified": "2026-10-09T12:00:08.202060202Z",
"provider": "osv",
"references": [
"https://lists.apache.org/thread.html/txn3br25kl657fh15rwcy1oht1xbpyyk",
"https://nvd.nist.gov/vuln/detail/CVE-2026-94276"
],
"provider_metadata": {
"cpes": [
"cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*"
],
"severity": "Medium"
}
},
"related_cves": [
{
"value": "CVE-2026-94276",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/database_specific/severity"
},
"source_id": "core-osv",
"document_id": 120658,
"published_at": "2026-10-09T10:43:51.802+00:00"
}