UnratedFix available
doctrine — security advisory
Multiple SQL injection vulnerabilities in the Doctrine\DBAL\Platforms\AbstractPlatform::modifyLimitQuery function in Doctrine 1.x before 1.2.4 and 2.x before 2.0.3 allow remote attackers to execute arbitrary SQL commands via the (1) limit or (2) offset field.
- Products
- doctrine
- Affected versions
- Not specified
- Fixed versions
- 1.2.4-1
- CVEs
- CVE-2011-1522
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 23:28 UTC · Revision 1
Source evidence
Multiple SQL injection vulnerabilities in the Doctrine\DBAL\Platforms\AbstractPlatform::modifyLimitQuery function in Doctrine 1.x before 1.2.4 and 2.x before 2.0.3 allow remote attackers to execute arbitrary SQL commands via the (1) limit or (2) offset field.
osv:DEBIAN-CVE-2011-1522
doctrine
Fixed versions: 1.2.4-1
doctrine
Fixed versions: 1.2.4-1
doctrine
Fixed versions: 1.2.4-1
Complete source record
{
"id": "0650432bf26e5205483fe1914b972e9942418bc458f4de8f7168154c82abb182",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2011-1522",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2011-1522",
"summary": "Multiple SQL injection vulnerabilities in the Doctrine\\DBAL\\Platforms\\AbstractPlatform::modifyLimitQuery function in Doctrine 1.x before 1.2.4 and 2.x before 2.0.3 allow remote attackers to execute arbitrary SQL commands via the (1) limit or (2) offset field.",
"evidence": "osv:DEBIAN-CVE-2011-1522",
"products": [
{
"name": {
"value": "doctrine",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.2.4-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "doctrine",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.2.4-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "doctrine",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.2.4-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2011-1522",
"aliases": [
"DEBIAN-CVE-2011-1522"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.2.4-1"
}
]
}
],
"package": {
"name": "doctrine",
"purl": "pkg:deb/debian/doctrine?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-1522.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.2.4-1"
}
]
}
],
"package": {
"name": "doctrine",
"purl": "pkg:deb/debian/doctrine?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-1522.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.2.4-1"
}
]
}
],
"package": {
"name": "doctrine",
"purl": "pkg:deb/debian/doctrine?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-1522.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T17:47:44.518625038Z",
"provider": "osv",
"upstream": [
"CVE-2011-1522"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2011-1522"
]
},
"related_cves": [
{
"value": "CVE-2011-1522",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 418662,
"published_at": "2011-05-03T20:55:06.51+00:00"
}