Skip to content
Heist/ feed
Back to feed
MediumFix available

apt — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2018-0501

The mirror:// method implementation in Advanced Package Tool (APT) 1.6.x before 1.6.4 and 1.7.x before 1.7.0~alpha3 mishandles gpg signature verification for the InRelease file of a fallback mirror, aka mirrorfail.

Products
apt
Affected versions
Not specified
Fixed versions
1.6.4
CVEs
CVE-2018-0501
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 00:24 UTC · Revision 1

Source evidence

DEBIAN-CVE-2018-0501

core-osv · Original source

Published 21 Aug 2018, 00:29 UTC

The mirror:// method implementation in Advanced Package Tool (APT) 1.6.x before 1.6.4 and 1.7.x before 1.7.0~alpha3 mishandles gpg signature verification for the InRelease file of a fallback mirror, aka mirrorfail.

osv:DEBIAN-CVE-2018-0501

apt

Fixed versions: 1.6.4

apt

Fixed versions: 1.6.4

apt

Fixed versions: 1.6.4

Complete source record
{
  "id": "bb248b0a57a5f10bce1e7fd67d75d00b8f1fa4648fe124f569fd8cd6837c43fe",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2018-0501",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2018-0501",
    "summary": "The mirror:// method implementation in Advanced Package Tool (APT) 1.6.x before 1.6.4 and 1.7.x before 1.7.0~alpha3 mishandles gpg signature verification for the InRelease file of a fallback mirror, aka mirrorfail.",
    "evidence": "osv:DEBIAN-CVE-2018-0501",
    "products": [
      {
        "name": {
          "value": "apt",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.6.4",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "apt",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.6.4",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "apt",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.6.4",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "DEBIAN-CVE-2018-0501",
      "aliases": [
        "DEBIAN-CVE-2018-0501"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.6.4"
                }
              ]
            }
          ],
          "package": {
            "name": "apt",
            "purl": "pkg:deb/debian/apt?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-0501.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.6.4"
                }
              ]
            }
          ],
          "package": {
            "name": "apt",
            "purl": "pkg:deb/debian/apt?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-0501.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.6.4"
                }
              ]
            }
          ],
          "package": {
            "name": "apt",
            "purl": "pkg:deb/debian/apt?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-0501.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T18:03:17.127922214Z",
      "provider": "osv",
      "upstream": [
        "CVE-2018-0501"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2018-0501"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2018-0501",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 421005,
  "published_at": "2018-08-21T00:29:00.227+00:00"
}