drupal/gin — security advisory
Gin is an administration theme that provides a modern, clean, and customizable backend UI for editors and site administrators. The module doesn't sufficiently sanitize certain attributes, which can lead to a cross-site scripting (XSS) vulnerability. This vulnerability is mitigated by the fact that an attacker must have a role with permission to enter HTML tags containing specific data attributes or the `administer menu` permission.
- Products
- drupal/gin
- Affected versions
- Not specified
- Fixed versions
- 4.1.4, 5.0.16
- CVEs
- CVE-2026-110738
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 12:37 UTC · Revision 1
Source evidence
Gin is an administration theme that provides a modern, clean, and customizable backend UI for editors and site administrators. The module doesn't sufficiently sanitize certain attributes, which can lead to a cross-site scripting (XSS) vulnerability. This vulnerability is mitigated by the fact that an attacker must have a role with permission to enter HTML tags containing specific data attributes or the `administer menu` permission.
osv:DRUPAL-CONTRIB-2026-219
drupal/gin
Fixed versions: 4.1.4, 5.0.16
Complete source record
{
"id": "734e93d8d8f7f56e201ecc02680570666be1c5f7058b51ebc8fd2db634f92f04",
"url": "https://osv.dev/vulnerability/DRUPAL-CONTRIB-2026-219",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DRUPAL-CONTRIB-2026-219",
"summary": "Gin is an administration theme that provides a modern, clean, and customizable backend UI for editors and site administrators. The module doesn't sufficiently sanitize certain attributes, which can lead to a cross-site scripting (XSS) vulnerability. This vulnerability is mitigated by the fact that an attacker must have a role with permission to enter HTML tags containing specific data attributes or the `administer menu` permission.",
"evidence": "osv:DRUPAL-CONTRIB-2026-219",
"products": [
{
"name": {
"value": "drupal/gin",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.1.4",
"evidence": "/affected/0/ranges"
},
{
"value": "5.0.16",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DRUPAL-CONTRIB-2026-219",
"aliases": [
"CVE-2026-110738",
"DRUPAL-CONTRIB-2026-219"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.1.4"
}
],
"database_specific": {
"constraint": "<4.1.4"
}
},
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "5.0.0"
},
{
"fixed": "5.0.16"
}
],
"database_specific": {
"constraint": ">=5.0.0 <5.0.16"
}
}
],
"package": {
"name": "drupal/gin",
"purl": "pkg:composer/drupal/gin?repository_url=https:%2F%2Fpackages.drupal.org%2F8",
"ecosystem": "Packagist:https://packages.drupal.org/8"
},
"database_specific": {
"source": "https://github.com/DrupalSecurityTeam/drupal-advisory-database/blob/main/advisories/gin/DRUPAL-CONTRIB-2026-219.json",
"affected_versions": "<4.1.4 || >=5.0.0 <5.0.16"
}
}
],
"modified": "2026-10-14T18:00:02.643642510Z",
"provider": "osv",
"references": [
"https://www.drupal.org/sa-contrib-2026-219"
]
},
"related_cves": [
{
"value": "CVE-2026-110738",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 317533,
"published_at": "2026-10-14T17:25:06+00:00"
}