Skip to content
Heist/ feed
Back to feed
UnratedFix available

wordpress — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2010-4536

Multiple cross-site scripting (XSS) vulnerabilities in KSES, as used in WordPress before 3.0.4, allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) the & (ampersand) character, (2) the case of an attribute name, (3) a padded entity, and (4) an entity that is not in normalized form.

Products
wordpress
Affected versions
Not specified
Fixed versions
3.0.4+dfsg-1
CVEs
CVE-2010-4536
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 22:55 UTC · Revision 1

Source evidence

DEBIAN-CVE-2010-4536

core-osv · Original source

Published 3 Jan 2011, 20:00 UTC

Multiple cross-site scripting (XSS) vulnerabilities in KSES, as used in WordPress before 3.0.4, allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) the & (ampersand) character, (2) the case of an attribute name, (3) a padded entity, and (4) an entity that is not in normalized form.

osv:DEBIAN-CVE-2010-4536

wordpress

Fixed versions: 3.0.4+dfsg-1

wordpress

Fixed versions: 3.0.4+dfsg-1

wordpress

Fixed versions: 3.0.4+dfsg-1

Complete source record
{
  "id": "96698051ab3bbe6277d29e5c92e039888e2c00bf3c64ca7269cea5fad7bcd46b",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2010-4536",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2010-4536",
    "summary": "Multiple cross-site scripting (XSS) vulnerabilities in KSES, as used in WordPress before 3.0.4, allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) the & (ampersand) character, (2) the case of an attribute name, (3) a padded entity, and (4) an entity that is not in normalized form.",
    "evidence": "osv:DEBIAN-CVE-2010-4536",
    "products": [
      {
        "name": {
          "value": "wordpress",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "3.0.4+dfsg-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "wordpress",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "3.0.4+dfsg-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "wordpress",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "3.0.4+dfsg-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "unknown",
    "structured": {
      "id": "DEBIAN-CVE-2010-4536",
      "aliases": [
        "DEBIAN-CVE-2010-4536"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "3.0.4+dfsg-1"
                }
              ]
            }
          ],
          "package": {
            "name": "wordpress",
            "purl": "pkg:deb/debian/wordpress?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2010-4536.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "3.0.4+dfsg-1"
                }
              ]
            }
          ],
          "package": {
            "name": "wordpress",
            "purl": "pkg:deb/debian/wordpress?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2010-4536.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "3.0.4+dfsg-1"
                }
              ]
            }
          ],
          "package": {
            "name": "wordpress",
            "purl": "pkg:deb/debian/wordpress?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2010-4536.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T17:47:29.557456897Z",
      "provider": "osv",
      "upstream": [
        "CVE-2010-4536"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2010-4536"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2010-4536",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "core-osv",
  "document_id": 417225,
  "published_at": "2011-01-03T20:00:43.42+00:00"
}