ckeditor, ckeditor3 — security advisory
CKEditor4 is an open source WYSIWYG HTML editor. In affected version a vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.
- Products
- ckeditor, ckeditor3
- Affected versions
- 3.6.6.1+dfsg-7
- Fixed versions
- 4.19.0+dfsg-1
- CVEs
- CVE-2021-41165
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 01:20 UTC · Revision 1
Source evidence
CKEditor4 is an open source WYSIWYG HTML editor. In affected version a vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.
osv:DEBIAN-CVE-2021-41165
ckeditor
Fixed versions: 4.19.0+dfsg-1
ckeditor3
Fixed versions: Not specified
Complete source record
{
"id": "0ba2044555fe54ca730ff42d6f838cc994ab9023a679c412af75d24aedbff298",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-41165",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2021-41165",
"summary": "CKEditor4 is an open source WYSIWYG HTML editor. In affected version a vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.",
"evidence": "osv:DEBIAN-CVE-2021-41165",
"products": [
{
"name": {
"value": "ckeditor",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.19.0+dfsg-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ckeditor3",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "3.6.6.1+dfsg-7",
"evidence": "/affected/1/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2021-41165",
"aliases": [
"DEBIAN-CVE-2021-41165"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.19.0+dfsg-1"
}
]
}
],
"package": {
"name": "ckeditor",
"purl": "pkg:deb/debian/ckeditor?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-41165.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "ckeditor3",
"purl": "pkg:deb/debian/ckeditor3?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"3.6.6.1+dfsg-7"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-41165.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:04:38.585893729Z",
"provider": "osv",
"upstream": [
"CVE-2021-41165"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2021-41165"
]
},
"related_cves": [
{
"value": "CVE-2021-41165",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 423590,
"published_at": "2021-11-17T20:15:10.273+00:00"
}