Skip to content
Heist/ feed
Back to feed
HighFix available

node-min — security advisory

Type: advisorySources: OSVAdvisory ID: BIT-node-min-2021-22940

Node.js before 16.6.1, 14.17.5, and 12.22.5 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.

Products
node-min
Affected versions
Not specified
Fixed versions
12.22.5, 14.17.5, 16.6.2
CVEs
CVE-2021-22940
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 19:54 UTC · Revision 1

Source evidence

BIT-node-min-2021-22940

core-osv · Original source

Published 16 Dec 2024, 14:04 UTC

Node.js before 16.6.1, 14.17.5, and 12.22.5 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.

osv:BIT-node-min-2021-22940

node-min

Fixed versions: 12.22.5, 14.17.5, 16.6.2

Complete source record
{
  "id": "0381be1a72d7f3de9c6972454aba12ddfae460ce838c1c57e3969bae1bb8c9e5",
  "url": "https://osv.dev/vulnerability/BIT-node-min-2021-22940",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "BIT-node-min-2021-22940",
    "summary": "Node.js before 16.6.1, 14.17.5, and 12.22.5 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.",
    "evidence": "osv:BIT-node-min-2021-22940",
    "products": [
      {
        "name": {
          "value": "node-min",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "12.22.5",
            "evidence": "/affected/0/ranges"
          },
          {
            "value": "14.17.5",
            "evidence": "/affected/0/ranges"
          },
          {
            "value": "16.6.2",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "BIT-node-min-2021-22940",
      "aliases": [
        "BIT-node-2021-22940",
        "BIT-node-min-2021-22940",
        "CVE-2021-22940"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "SEMVER",
              "events": [
                {
                  "introduced": "12.0.0"
                },
                {
                  "fixed": "12.22.5"
                },
                {
                  "introduced": "14.0.0"
                },
                {
                  "fixed": "14.17.5"
                },
                {
                  "introduced": "16.0.0"
                },
                {
                  "fixed": "16.6.2"
                }
              ]
            }
          ],
          "package": {
            "name": "node-min",
            "purl": "pkg:bitnami/node-min",
            "ecosystem": "Bitnami"
          },
          "severity": [
            {
              "type": "CVSS_V3",
              "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N"
            }
          ],
          "database_specific": {
            "source": "https://github.com/bitnami/vulndb/tree/main/data/node-min/BIT-node-min-2021-22940.json"
          }
        }
      ],
      "modified": "2026-10-16T09:45:28.344570083Z",
      "provider": "osv",
      "references": [
        "https://hackerone.com/reports/1238162",
        "https://lists.debian.org/debian-lts-announce/2022/10/msg00006.html",
        "https://nodejs.org/en/blog/vulnerability/aug-2021-security-releases/",
        "https://security.gentoo.org/glsa/202401-02",
        "https://security.netapp.com/advisory/ntap-20210923-0001/",
        "https://www.oracle.com/security-alerts/cpujan2022.html",
        "https://www.oracle.com/security-alerts/cpujul2022.html",
        "https://www.oracle.com/security-alerts/cpuoct2021.html",
        "https://nvd.nist.gov/vuln/detail/CVE-2021-22940"
      ],
      "provider_metadata": {
        "cpes": [
          "cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:*",
          "cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:*"
        ],
        "severity": "High"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2021-22940",
        "evidence": "/aliases"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/database_specific/severity"
  },
  "source_id": "core-osv",
  "document_id": 338456,
  "published_at": "2024-12-16T14:04:54.112+00:00"
}