xrdp — security advisory
xrdp is an open source remote desktop protocol (RDP) server. In versions prior to 0.9.23 improper handling of session establishment errors allows bypassing OS-level session restrictions. The `auth_start_session` function can return non-zero (1) value on, e.g., PAM error which may result in in session restrictions such as max concurrent sessions per user by PAM (ex ./etc/security/limits.conf) to be bypassed. Users (administrators) don't use restrictions by PAM are not affected. This issue has been addressed in release version 0.9.23. Users are advised to upgrade. There are no known workarounds for this issue.
- Products
- xrdp
- Affected versions
- 0.9.21.1-1
- Fixed versions
- 0.9.21.1-1+deb12u1, 0.9.24-2
- CVEs
- CVE-2023-40184
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 15:57 UTC · Revision 1
Source evidence
xrdp is an open source remote desktop protocol (RDP) server. In versions prior to 0.9.23 improper handling of session establishment errors allows bypassing OS-level session restrictions. The `auth_start_session` function can return non-zero (1) value on, e.g., PAM error which may result in in session restrictions such as max concurrent sessions per user by PAM (ex ./etc/security/limits.conf) to be bypassed. Users (administrators) don't use restrictions by PAM are not affected. This issue has been addressed in release version 0.9.23. Users are advised to upgrade. There are no known workarounds for this issue.
osv:DEBIAN-CVE-2023-40184
xrdp
Fixed versions: 0.9.21.1-1+deb12u1
xrdp
Fixed versions: 0.9.24-2
xrdp
Fixed versions: 0.9.24-2
Complete source record
{
"id": "83a80f080b72fd7d38e9df8b7c783df854c9b7fdd5ca964d28b53af0bdfa0048",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-40184",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-40184",
"summary": "xrdp is an open source remote desktop protocol (RDP) server. In versions prior to 0.9.23 improper handling of session establishment errors allows bypassing OS-level session restrictions. The `auth_start_session` function can return non-zero (1) value on, e.g., PAM error which may result in in session restrictions such as max concurrent sessions per user by PAM (ex ./etc/security/limits.conf) to be bypassed. Users (administrators) don't use restrictions by PAM are not affected. This issue has been addressed in release version 0.9.23. Users are advised to upgrade. There are no known workarounds for this issue.",
"evidence": "osv:DEBIAN-CVE-2023-40184",
"products": [
{
"name": {
"value": "xrdp",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.9.21.1-1+deb12u1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "0.9.21.1-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "xrdp",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.9.24-2",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "xrdp",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.9.24-2",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2023-40184",
"aliases": [
"DEBIAN-CVE-2023-40184"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.9.21.1-1+deb12u1"
}
]
}
],
"package": {
"name": "xrdp",
"purl": "pkg:deb/debian/xrdp?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"0.9.21.1-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-40184.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.9.24-2"
}
]
}
],
"package": {
"name": "xrdp",
"purl": "pkg:deb/debian/xrdp?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-40184.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.9.24-2"
}
]
}
],
"package": {
"name": "xrdp",
"purl": "pkg:deb/debian/xrdp?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-40184.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T18:02:32.444289893Z",
"provider": "osv",
"upstream": [
"CVE-2023-40184"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-40184"
]
},
"related_cves": [
{
"value": "CVE-2023-40184",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 456207,
"published_at": "2023-08-30T18:15:09.69+00:00"
}