bcel, openjdk-17 — security advisory
The Apache Xalan Java XSLT library is vulnerable to an integer truncation issue when processing malicious XSLT stylesheets. This can be used to corrupt Java class files generated by the internal XSLTC compiler and execute arbitrary Java bytecode. Users are recommended to update to version 2.7.3 or later. Note: Java runtimes (such as OpenJDK) include repackaged copies of Xalan.
- Products
- bcel, openjdk-17
- Affected versions
- Not specified
- Fixed versions
- 17.0.4+8-1, 6.5.0-2
- CVEs
- CVE-2022-34169
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:30 UTC · Revision 1
Source evidence
The Apache Xalan Java XSLT library is vulnerable to an integer truncation issue when processing malicious XSLT stylesheets. This can be used to corrupt Java class files generated by the internal XSLTC compiler and execute arbitrary Java bytecode. Users are recommended to update to version 2.7.3 or later. Note: Java runtimes (such as OpenJDK) include repackaged copies of Xalan.
osv:DEBIAN-CVE-2022-34169
bcel
Fixed versions: 6.5.0-2
bcel
Fixed versions: 6.5.0-2
bcel
Fixed versions: 6.5.0-2
openjdk-17
Fixed versions: 17.0.4+8-1
Complete source record
{
"id": "10c74231149b71731d028339afa8e929bcc93fda0816594c080f9c192d3c194a",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-34169",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-34169",
"summary": "The Apache Xalan Java XSLT library is vulnerable to an integer truncation issue when processing malicious XSLT stylesheets. This can be used to corrupt Java class files generated by the internal XSLTC compiler and execute arbitrary Java bytecode. Users are recommended to update to version 2.7.3 or later. Note: Java runtimes (such as OpenJDK) include repackaged copies of Xalan.",
"evidence": "osv:DEBIAN-CVE-2022-34169",
"products": [
{
"name": {
"value": "bcel",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "6.5.0-2",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "bcel",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "6.5.0-2",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "bcel",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "6.5.0-2",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "openjdk-17",
"evidence": "/affected/3/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "17.0.4+8-1",
"evidence": "/affected/3/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-34169",
"aliases": [
"DEBIAN-CVE-2022-34169"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "6.5.0-2"
}
]
}
],
"package": {
"name": "bcel",
"purl": "pkg:deb/debian/bcel?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-34169.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "6.5.0-2"
}
]
}
],
"package": {
"name": "bcel",
"purl": "pkg:deb/debian/bcel?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-34169.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "6.5.0-2"
}
]
}
],
"package": {
"name": "bcel",
"purl": "pkg:deb/debian/bcel?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-34169.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "17.0.4+8-1"
}
]
}
],
"package": {
"name": "openjdk-17",
"purl": "pkg:deb/debian/openjdk-17?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-34169.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:00:14.348422352Z",
"provider": "osv",
"upstream": [
"CVE-2022-34169"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-34169"
]
},
"related_cves": [
{
"value": "CVE-2022-34169",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 322398,
"published_at": "2022-07-19T18:15:11.74+00:00"
}