Skip to content
Heist/ feed
Back to feed
High

GoBGP: Remote Denial of Service (Panic) in UpdatePathAttrs4ByteAs via Malformed BGP UPDATE

Type: advisorySources: OSV

GoBGP is an open source Border Gateway Protocol (BGP) implementation in the Go Programming Language. Prior to version 4.3.0, a remote Denial of Service (DoS) vulnerability exists in GoBGP where a malformed BGP UPDATE message can trigger a runtime error: index out of range panic. This occurs during the processing of 4-byte AS attributes when the message structure causes an internal slice index shift that is not properly handled. This issue has been patched in version 4.3.0.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-41643
Confirmed fixed CVEs
Not specified
Updated in this feed
5 Nov 2026, 06:01 UTC · Revision 1

Source evidence

GoBGP: Remote Denial of Service (Panic) in UpdatePathAttrs4ByteAs via Malformed BGP UPDATE

core-osv · Original source

Published 7 May 2026, 11:53 UTC

GoBGP is an open source Border Gateway Protocol (BGP) implementation in the Go Programming Language. Prior to version 4.3.0, a remote Denial of Service (DoS) vulnerability exists in GoBGP where a malformed BGP UPDATE message can trigger a runtime error: index out of range panic. This occurs during the processing of 4-byte AS attributes when the message structure causes an internal slice index shift that is not properly handled. This issue has been patched in version 4.3.0.

osv:CVE-2026-41643
Complete source record
{
  "id": "02dac17b808e52184291b9c2bdff77dcc229af335fd23eaed923966fd69fd343",
  "url": "https://osv.dev/vulnerability/CVE-2026-41643",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "GoBGP: Remote Denial of Service (Panic) in UpdatePathAttrs4ByteAs via Malformed BGP UPDATE",
    "summary": "GoBGP is an open source Border Gateway Protocol (BGP) implementation in the Go Programming Language. Prior to version 4.3.0, a remote Denial of Service (DoS) vulnerability exists in GoBGP where a malformed BGP UPDATE message can trigger a runtime error: index out of range panic. This occurs during the processing of 4-byte AS attributes when the message structure causes an internal slice index shift that is not properly handled. This issue has been patched in version 4.3.0.",
    "evidence": "osv:CVE-2026-41643",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2026-41643",
      "aliases": [
        "CVE-2026-41643",
        "GHSA-8rxh-r2p6-7f2q",
        "GO-2026-5266"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/osrg/gobgp",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "c3eb0db6df91379e15ce1a8709cb1b64f482248e"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "4.3.0"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "fixed": "c3eb0db6df91379e15ce1a8709cb1b64f482248e"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v4.3.0"
                  },
                  {
                    "cpe": "cpe:2.3:a:osrg:gobgp:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "4.3.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v4.2.0",
            "v4.1.0",
            "v4.0.0",
            "v3.37.0",
            "v3.36.0",
            "v3.35.0",
            "v3.34.0",
            "v3.33.0",
            "v3.32.0",
            "v3.31.0",
            "v3.30.0",
            "v3.29.0",
            "v3.28.0",
            "v3.27.0",
            "v3.26.0",
            "v3.25.0",
            "v3.24.0",
            "v3.23.0",
            "v3.22.0",
            "v3.21.0",
            "v3.20.0",
            "v3.19.0",
            "v3.17.0",
            "v3.16.0",
            "v3.15.0",
            "v3.14.0",
            "v3.13.0",
            "v3.12.0",
            "v3.11.0",
            "v3.10.0",
            "v3.9.0",
            "v3.8.0",
            "v3.7.0",
            "v3.6.0",
            "v3.5.0",
            "v3.4.0",
            "v3.3.0",
            "v3.2.0",
            "v3.1.0",
            "v3.0.0",
            "v3.0.0-rc4",
            "v3.0.0-rc3",
            "v3.0.0-rc2",
            "v3.0.0-rc1",
            "v2.34.0",
            "v2.33.0",
            "v2.32.0",
            "v2.31.0",
            "v2.30.0",
            "v2.29.0",
            "v2.28.0",
            "v2.27.0",
            "v2.26.0",
            "v2.25.0",
            "v2.24.0",
            "v2.23.0",
            "v2.22.0",
            "v2.21.0",
            "v2.20.0",
            "v2.19.0",
            "v2.18.0",
            "v2.17.0",
            "v2.16.0",
            "v2.15.0",
            "v2.14.0",
            "v2.13.0",
            "v2.12.0",
            "v2.11.0",
            "v2.10.0",
            "v2.9.0",
            "v2.8.0",
            "v2.7.0",
            "v2.6.0",
            "v2.5.0",
            "v2.4.0",
            "v2.3.0",
            "v2.2.0",
            "v2.1.0",
            "v2.0.0",
            "v1.33",
            "v1.32",
            "v1.31",
            "v1.30",
            "v1.29",
            "v1.28",
            "v1.27",
            "v1.26",
            "v1.25",
            "v1.24",
            "v1.23",
            "v1.22",
            "v1.21",
            "v1.20",
            "v1.19",
            "v1.18",
            "v1.17",
            "v1.16",
            "v1.15",
            "v1.14",
            "v1.13",
            "v1.12",
            "v1.11",
            "v1.10",
            "v1.9",
            "v1.8",
            "v1.7",
            "v1.6",
            "v1.5",
            "v1.4",
            "v1.3",
            "v1.2",
            "v1.1",
            "v1.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-41643.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:42.951235644Z",
      "provider": "osv",
      "references": [
        "https://github.com/osrg/gobgp/releases/tag/v4.3.0",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/41xxx/CVE-2026-41643.json",
        "https://github.com/osrg/gobgp/security/advisories/GHSA-8rxh-r2p6-7f2q",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-41643"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-129"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/41xxx/CVE-2026-41643.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-41643",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 510920,
  "published_at": "2026-05-07T11:53:23.566+00:00"
}