Skip to content
Heist/ feed
Back to feed
Medium

Regular expression denial of service in dparse

Type: advisorySources: OSV

dparse is a parser for Python dependency files. dparse in versions before 0.5.2 contain a regular expression that is vulnerable to a Regular Expression Denial of Service. All the users parsing index server URLs with dparse are impacted by this vulnerability. A patch has been applied in version `0.5.2`, all the users are advised to upgrade to `0.5.2` as soon as possible. Users unable to upgrade should avoid passing index server URLs in the source file to be parsed.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2022-39280
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 18:04 UTC · Revision 1

Source evidence

Regular expression denial of service in dparse

core-osv · Original source

Published 6 Oct 2022, 00:00 UTC

dparse is a parser for Python dependency files. dparse in versions before 0.5.2 contain a regular expression that is vulnerable to a Regular Expression Denial of Service. All the users parsing index server URLs with dparse are impacted by this vulnerability. A patch has been applied in version `0.5.2`, all the users are advised to upgrade to `0.5.2` as soon as possible. Users unable to upgrade should avoid passing index server URLs in the source file to be parsed.

osv:CVE-2022-39280
Complete source record
{
  "id": "0ace2540a57d35e9bd914f154b94d0c770633d7c6ab4743f07ec7cc24b7919bc",
  "url": "https://osv.dev/vulnerability/CVE-2022-39280",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Regular expression denial of service in dparse",
    "summary": "dparse is a parser for Python dependency files. dparse in versions before 0.5.2 contain a regular expression that is vulnerable to a Regular Expression Denial of Service. All the users parsing index server URLs with dparse are impacted by this vulnerability. A patch has been applied in version `0.5.2`, all the users are advised to upgrade to `0.5.2` as soon as possible. Users unable to upgrade should avoid passing index server URLs in the source file to be parsed.",
    "evidence": "osv:CVE-2022-39280",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2022-39280",
      "aliases": [
        "CVE-2022-39280",
        "GHSA-8fg9-p83m-x5pq",
        "PYSEC-2022-301"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/pyupio/dparse",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "a3d9beb0f97331bdc0cb83ec628131e89b8c68d2"
                },
                {
                  "fixed": "8c990170bbd6c0cf212f1151e9025486556062d5"
                },
                {
                  "fixed": "d87364f9db9ab916451b1b036cfeb039e726e614"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:pyup:dependency_parser:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "0.5.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "8c990170bbd6c0cf212f1151e9025486556062d5"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "range": [
                      {
                        "fixed": "d87364f9db9ab916451b1b036cfeb039e726e614"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "0.5.0",
            "0.4.1",
            "0.4",
            "0.3.0",
            "0.2.1",
            "0.2.0",
            "0.1.1",
            "0.1.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-39280.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:38.284782514Z",
      "provider": "osv",
      "references": [
        "https://owasp.org/www-community/attacks/Regular_expression_Denial_of_Service_-_ReDoS",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39280.json",
        "https://github.com/pyupio/dparse/security/advisories/GHSA-8fg9-p83m-x5pq",
        "https://nvd.nist.gov/vuln/detail/CVE-2022-39280",
        "https://github.com/pyupio/dparse/commit/8c990170bbd6c0cf212f1151e9025486556062d5",
        "https://github.com/pyupio/dparse/commit/d87364f9db9ab916451b1b036cfeb039e726e614"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-400"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39280.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2022-39280",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 505578,
  "published_at": "2022-10-06T00:00:00+00:00"
}