High
Caddy forward_auth copy_headers Does Not Strip Client-Supplied Headers, Allowing Identity Injection and Privilege Escalation
Type: advisorySources: OSV
Caddy is an extensible server platform that uses TLS by default. From version 2.10.0 to before version 2.11.2, forward_auth copy_headers does not strip client-supplied headers, allowing identity injection and privilege escalation. This issue has been patched in version 2.11.2.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-30851
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 05:13 UTC · Revision 1
Source evidence
Caddy forward_auth copy_headers Does Not Strip Client-Supplied Headers, Allowing Identity Injection and Privilege Escalation
core-osv · Original sourcePublished 7 Mar 2026, 16:28 UTC
Caddy is an extensible server platform that uses TLS by default. From version 2.10.0 to before version 2.11.2, forward_auth copy_headers does not strip client-supplied headers, allowing identity injection and privilege escalation. This issue has been patched in version 2.11.2.
osv:CVE-2026-30851
Complete source record
{
"id": "72b32cc570f89877e1831fb3e0bfeba1460fc17b072f3e076e80b20c358b1043",
"url": "https://osv.dev/vulnerability/CVE-2026-30851",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Caddy forward_auth copy_headers Does Not Strip Client-Supplied Headers, Allowing Identity Injection and Privilege Escalation",
"summary": "Caddy is an extensible server platform that uses TLS by default. From version 2.10.0 to before version 2.11.2, forward_auth copy_headers does not strip client-supplied headers, allowing identity injection and privilege escalation. This issue has been patched in version 2.11.2.",
"evidence": "osv:CVE-2026-30851",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-30851",
"aliases": [
"CVE-2026-30851",
"GHSA-7r4p-vjf4-gxv4",
"GO-2026-4639"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/caddyserver/caddy",
"type": "GIT",
"events": [
{
"introduced": "fb22a26b1a08a2fa3b2526d1852467904ee140f6"
},
{
"fixed": "ffb6ab0644f24c5ee6542aca6bd59b7a1b0a8f91"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "2.10.0"
},
{
"fixed": "2.11.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"cpe": "cpe:2.3:a:caddyserver:caddy:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.10.0"
},
{
"fixed": "2.11.2"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v2.11.1",
"v2.11.0",
"v2.11.0-beta.2",
"v2.11.0-beta.1",
"v2.10.2",
"v2.10.1",
"v2.10.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-30851.json"
}
}
],
"modified": "2026-10-28T02:30:33.259011558Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/30xxx/CVE-2026-30851.json",
"https://github.com/caddyserver/caddy/security/advisories/GHSA-7r4p-vjf4-gxv4",
"https://nvd.nist.gov/vuln/detail/CVE-2026-30851",
"https://github.com/caddyserver/caddy/issues/6610",
"https://github.com/caddyserver/caddy/pull/6608",
"https://github.com/caddyserver/caddy/pull/7545"
],
"provider_metadata": {
"cwe_ids": [
"CWE-287",
"CWE-345"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/30xxx/CVE-2026-30851.json"
}
},
"related_cves": [
{
"value": "CVE-2026-30851",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 500455,
"published_at": "2026-03-07T16:28:37.097+00:00"
}