MediumFix available
wolfssl — security advisory
It was found that wolfssl before 3.15.7 is vulnerable to a new variant of the Bleichenbacher attack to perform downgrade attacks against TLS. This may lead to leakage of sensible data.
- Products
- wolfssl
- Affected versions
- Not specified
- Fixed versions
- 4.1.0+dfsg-1
- CVEs
- CVE-2018-16870
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 00:28 UTC · Revision 1
Source evidence
It was found that wolfssl before 3.15.7 is vulnerable to a new variant of the Bleichenbacher attack to perform downgrade attacks against TLS. This may lead to leakage of sensible data.
osv:DEBIAN-CVE-2018-16870
wolfssl
Fixed versions: 4.1.0+dfsg-1
wolfssl
Fixed versions: 4.1.0+dfsg-1
Complete source record
{
"id": "f3c08e886531ba0f18f18d58a4a6eb088919e2a065022fee302b7359fde641a7",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2018-16870",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2018-16870",
"summary": "It was found that wolfssl before 3.15.7 is vulnerable to a new variant of the Bleichenbacher attack to perform downgrade attacks against TLS. This may lead to leakage of sensible data.",
"evidence": "osv:DEBIAN-CVE-2018-16870",
"products": [
{
"name": {
"value": "wolfssl",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.1.0+dfsg-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "wolfssl",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.1.0+dfsg-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2018-16870",
"aliases": [
"DEBIAN-CVE-2018-16870"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.1.0+dfsg-1"
}
]
}
],
"package": {
"name": "wolfssl",
"purl": "pkg:deb/debian/wolfssl?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-16870.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.1.0+dfsg-1"
}
]
}
],
"package": {
"name": "wolfssl",
"purl": "pkg:deb/debian/wolfssl?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-16870.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:03:19.928307899Z",
"provider": "osv",
"upstream": [
"CVE-2018-16870"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2018-16870"
]
},
"related_cves": [
{
"value": "CVE-2018-16870",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 421176,
"published_at": "2019-01-03T16:29:00.227+00:00"
}