MediumFix available
GitLab Patch Release: 17.7.1, 17.6.3, 17.5.5
Type: patchSources: GitLab patch releases
GitLab released security fixes in GitLab CE/EE versions 17.7.1, 17.6.3, and 17.5.5. The announcement recommends that affected installations upgrade; it also advises disabling importers until upgraded to 17.7.1 or later.
- Products
- GitLab CE/EE
- Affected versions
- 17.6 before 17.6.3, 17.7 before 17.7.1, all versions starting from 15.5 before 17.5.5, all versions starting from 15.7 prior to 17.5.5, all versions starting from 16.4 prior to 17.5.5, all versions starting from 17.4 prior to 17.5.5, starting from 17.6 prior to 17.6.3, starting from 17.7 prior to 17.7.1
- Fixed versions
- 17.5.5, 17.6.3, 17.7.1
- CVEs
- CVE-2024-12431, CVE-2024-13041, CVE-2024-5655, CVE-2024-6324, CVE-2024-6385, CVE-2024-6678, CVE-2024-8970, CVE-2025-0194
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 03:55 UTC · Revision 1
Source evidence
GitLab Patch Release: 17.7.1, 17.6.3, 17.5.5
official-gitlab-security-releases · Original sourcePublished 8 Jan 2025, 00:00 UTC
GitLab released security fixes in GitLab CE/EE versions 17.7.1, 17.6.3, and 17.5.5. The announcement recommends that affected installations upgrade; it also advises disabling importers until upgraded to 17.7.1 or later.
On January 8, 2025, we released versions 17.7.1, 17.6.3, 17.5.5 for GitLab Community Edition (CE) and Enterprise Edition (EE). These versions contain important bug and security fixes
GitLab CE/EE
Fixed versions: 17.7.1, 17.6.3, 17.5.5
Prerequisites: an attacker have an authenticated user account on the target GitLab instance; GitLab Self-Managed with Direct Transfer (beta feature) or GitHub, Bitbucket Server, or Gitea importers enabled
Complete source record
{
"id": "80699c422e9b2a768f33d5d67709336bb736f90df29254290c38c7c2ce6b0bf6",
"url": "https://docs.gitlab.com/releases/patches/patch-release-gitlab-17-7-1-released/",
"method": "llm",
"payload": {
"kind": "patch",
"title": "GitLab Patch Release: 17.7.1, 17.6.3, 17.5.5",
"summary": "GitLab released security fixes in GitLab CE/EE versions 17.7.1, 17.6.3, and 17.5.5. The announcement recommends that affected installations upgrade; it also advises disabling importers until upgraded to 17.7.1 or later.",
"evidence": "On January 8, 2025, we released versions 17.7.1, 17.6.3, 17.5.5 for GitLab Community Edition (CE) and Enterprise Edition (EE). These versions contain important bug and security fixes",
"products": [
{
"name": {
"value": "GitLab CE/EE",
"evidence": "An issue was discovered in GitLab CE/EE affecting all versions starting from 17.4 prior to 17.5.5"
},
"prerequisites": [
{
"value": "an attacker have an authenticated user account on the target GitLab instance",
"evidence": "Exploitation requires that an attacker have an authenticated user account on the target GitLab instance."
},
{
"value": "GitLab Self-Managed with Direct Transfer (beta feature) or GitHub, Bitbucket Server, or Gitea importers enabled",
"evidence": "GitLab Self-Managed with Direct Transfer (beta feature) or GitHub, Bitbucket Server, or Gitea importers enabled may be vulnerable"
}
],
"fixed_versions": [
{
"value": "17.7.1",
"evidence": "On January 8, 2025, we released versions 17.7.1, 17.6.3, 17.5.5 for GitLab Community Edition (CE) and Enterprise Edition (EE)."
},
{
"value": "17.6.3",
"evidence": "On January 8, 2025, we released versions 17.7.1, 17.6.3, 17.5.5 for GitLab Community Edition (CE) and Enterprise Edition (EE)."
},
{
"value": "17.5.5",
"evidence": "On January 8, 2025, we released versions 17.7.1, 17.6.3, 17.5.5 for GitLab Community Edition (CE) and Enterprise Edition (EE)."
}
],
"affected_versions": [
{
"value": "all versions starting from 17.4 prior to 17.5.5",
"evidence": "An issue was discovered in GitLab CE/EE affecting all versions starting from 17.4 prior to 17.5.5, starting from 17.6 prior to 17.6.3, and starting from 17.7 prior to 17.7.1."
},
{
"value": "starting from 17.6 prior to 17.6.3",
"evidence": "An issue was discovered in GitLab CE/EE affecting all versions starting from 17.4 prior to 17.5.5, starting from 17.6 prior to 17.6.3, and starting from 17.7 prior to 17.7.1."
},
{
"value": "starting from 17.7 prior to 17.7.1",
"evidence": "An issue was discovered in GitLab CE/EE affecting all versions starting from 17.4 prior to 17.5.5, starting from 17.6 prior to 17.6.3, and starting from 17.7 prior to 17.7.1."
},
{
"value": "all versions starting from 15.7 prior to 17.5.5",
"evidence": "An issue was discovered in GitLab CE/EE affecting all versions starting from 15.7 prior to 17.5.5, starting from 17.6 prior to 17.6.3, and starting from 17.7 prior to 17.7.1."
},
{
"value": "all versions starting from 15.5 before 17.5.5",
"evidence": "An issue was discovered in GitLab CE/EE affecting all versions starting from 15.5 before 17.5.5, 17.6 before 17.6.3, and 17.7 before 17.7.1"
},
{
"value": "17.6 before 17.6.3",
"evidence": "An issue was discovered in GitLab CE/EE affecting all versions starting from 15.5 before 17.5.5, 17.6 before 17.6.3, and 17.7 before 17.7.1"
},
{
"value": "17.7 before 17.7.1",
"evidence": "An issue was discovered in GitLab CE/EE affecting all versions starting from 15.5 before 17.5.5, 17.6 before 17.6.3, and 17.7 before 17.7.1"
},
{
"value": "all versions starting from 16.4 prior to 17.5.5",
"evidence": "An issue was discovered in GitLab CE/EE affecting all versions starting from 16.4 prior to 17.5.5, starting from 17.6 prior to 17.6.3, and starting from 17.7 prior to 17.7.1."
}
]
}
],
"severity": "medium",
"fixed_cves": [],
"related_cves": [
{
"value": "CVE-2024-5655",
"evidence": "Vulnerabilities (CVE-2024-5655, CVE-2024-6385, CVE-2024-6678, CVE-2024-8970) affecting import functionality were discovered through our HackerOne bug bounty program."
},
{
"value": "CVE-2024-6385",
"evidence": "Vulnerabilities (CVE-2024-5655, CVE-2024-6385, CVE-2024-6678, CVE-2024-8970) affecting import functionality were discovered through our HackerOne bug bounty program."
},
{
"value": "CVE-2024-6678",
"evidence": "Vulnerabilities (CVE-2024-5655, CVE-2024-6385, CVE-2024-6678, CVE-2024-8970) affecting import functionality were discovered through our HackerOne bug bounty program."
},
{
"value": "CVE-2024-8970",
"evidence": "Vulnerabilities (CVE-2024-5655, CVE-2024-6385, CVE-2024-6678, CVE-2024-8970) affecting import functionality were discovered through our HackerOne bug bounty program."
},
{
"value": "CVE-2025-0194",
"evidence": "It is now mitigated in the latest release and is assigned CVE-2025-0194."
},
{
"value": "CVE-2024-6324",
"evidence": "It is now mitigated in the latest release and is assigned CVE-2024-6324."
},
{
"value": "CVE-2024-12431",
"evidence": "It is now mitigated in the latest release and is assigned CVE-2024-12431."
},
{
"value": "CVE-2024-13041",
"evidence": "It is now mitigated in the latest release and is assigned CVE-2024-13041."
}
],
"security_relevant": true,
"severity_evidence": "This is a medium severity issue (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N, 6.5)."
},
"source_id": "official-gitlab-security-releases",
"document_id": 23795,
"published_at": "2025-01-08T00:00:00+00:00"
}