UnratedFix available
phpmyadmin — security advisory
Cross-site scripting (XSS) vulnerability in import.php in phpMyAdmin before 4.1.7 allows remote authenticated users to inject arbitrary web script or HTML via a crafted filename in an import action.
- Products
- phpmyadmin
- Affected versions
- Not specified
- Fixed versions
- 4:4.1.7-1
- CVEs
- CVE-2014-1879
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 21:47 UTC · Revision 1
Source evidence
Cross-site scripting (XSS) vulnerability in import.php in phpMyAdmin before 4.1.7 allows remote authenticated users to inject arbitrary web script or HTML via a crafted filename in an import action.
osv:DEBIAN-CVE-2014-1879
phpmyadmin
Fixed versions: 4:4.1.7-1
phpmyadmin
Fixed versions: 4:4.1.7-1
phpmyadmin
Fixed versions: 4:4.1.7-1
Complete source record
{
"id": "082968bb7e53acb02f608471f1881fad3f52abced39f15f01b01cfbbc405c5f8",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-1879",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2014-1879",
"summary": "Cross-site scripting (XSS) vulnerability in import.php in phpMyAdmin before 4.1.7 allows remote authenticated users to inject arbitrary web script or HTML via a crafted filename in an import action.",
"evidence": "osv:DEBIAN-CVE-2014-1879",
"products": [
{
"name": {
"value": "phpmyadmin",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4:4.1.7-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "phpmyadmin",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4:4.1.7-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "phpmyadmin",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4:4.1.7-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2014-1879",
"aliases": [
"DEBIAN-CVE-2014-1879"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4:4.1.7-1"
}
]
}
],
"package": {
"name": "phpmyadmin",
"purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-1879.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4:4.1.7-1"
}
]
}
],
"package": {
"name": "phpmyadmin",
"purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-1879.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4:4.1.7-1"
}
]
}
],
"package": {
"name": "phpmyadmin",
"purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-1879.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
}
],
"modified": "2026-10-23T15:47:38.860244744Z",
"provider": "osv",
"upstream": [
"CVE-2014-1879"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2014-1879"
]
},
"related_cves": [
{
"value": "CVE-2014-1879",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 414469,
"published_at": "2014-02-20T15:27:09.547+00:00"
}