High
Apache APISIX: Openid-connect `tls_verify` field is disabled by default
Type: advisorySources: OSV
Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX. This can occur due to `ssl_verify` in openid-connect plugin configuration being set to false by default. This issue affects Apache APISIX: from 0.7 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-31923
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 04:25 UTC · Revision 1
Source evidence
Apache APISIX: Openid-connect `tls_verify` field is disabled by default
core-osv · Original sourcePublished 14 Apr 2026, 08:38 UTC
Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX. This can occur due to `ssl_verify` in openid-connect plugin configuration being set to false by default. This issue affects Apache APISIX: from 0.7 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.
osv:CVE-2026-31923
Complete source record
{
"id": "545cb5cae3e65f2d744af2b1e4edbf3c07c2ed87629907d86c14e7fda39d8fff",
"url": "https://osv.dev/vulnerability/CVE-2026-31923",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache APISIX: Openid-connect `tls_verify` field is disabled by default",
"summary": "Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX. This can occur due to `ssl_verify` in openid-connect plugin configuration being set to false by default. This issue affects Apache APISIX: from 0.7 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.",
"evidence": "osv:CVE-2026-31923",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-31923",
"aliases": [
"BIT-apisix-2026-31923",
"CVE-2026-31923"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/apisix",
"type": "GIT",
"events": [
{
"introduced": "71920bc606bd0381291f2cbe9bc1aa24cc89a52e"
},
{
"fixed": "f9c4ee37170bdfe075c846973c1be65a582a0c4f"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0.7"
},
{
"fixed": "3.16.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"3.9.0",
"3.8.0",
"3.7.0",
"3.6.0",
"3.2.0",
"v0.9",
"0.9-RC1",
"v0.7"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-31923.json"
}
}
],
"modified": "2026-10-28T02:30:49.634689096Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/31xxx/CVE-2026-31923.json",
"https://lists.apache.org/thread/0pjs72l7qj83j3srw1l1toyj24bsgkds",
"https://nvd.nist.gov/vuln/detail/CVE-2026-31923"
],
"provider_metadata": {
"cwe_ids": [
"CWE-319"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "0.7"
},
{
"last_affected": "3.15.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/31xxx/CVE-2026-31923.json"
}
},
"related_cves": [
{
"value": "CVE-2026-31923",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 518113,
"published_at": "2026-04-14T08:38:59.039+00:00"
}