Skip to content
Heist/ feed
Back to feed
Critical

mongoose — security advisory

Type: advisorySources: OSVAdvisory ID: UBUNTU-CVE-2026-73256

Mongoose is an embedded web server and network library. Prior to 7.22, a remote unauthenticated attacker can exploit an HTTP/1.0 reverse-proxy deployment by sending a request with Transfer-Encoding: chunked and conflicting framing. The http_cb() function in src/http.c tests hm.proto.len with an impossible greater-than-eight condition even though mg_http_parse() requires an eight-byte protocol string, so is_http_1_0 is never set. Mongoose consequently processes chunked encoding that an HTTP/1.0 proxy can ignore, enabling request smuggling and unauthorized access or state changes. This issue is fixed in version 7.22.

Products
mongoose
Affected versions
7.21+ds-1, 7.21+ds-2, 7.22+ds-1, 7.23+ds-1
Fixed versions
Not specified
CVEs
CVE-2026-73256
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 03:15 UTC · Revision 1

Source evidence

UBUNTU-CVE-2026-73256

core-osv · Original source

Published 20 Aug 2026, 18:16 UTC

Mongoose is an embedded web server and network library. Prior to 7.22, a remote unauthenticated attacker can exploit an HTTP/1.0 reverse-proxy deployment by sending a request with Transfer-Encoding: chunked and conflicting framing. The http_cb() function in src/http.c tests hm.proto.len with an impossible greater-than-eight condition even though mg_http_parse() requires an eight-byte protocol string, so is_http_1_0 is never set. Mongoose consequently processes chunked encoding that an HTTP/1.0 proxy can ignore, enabling request smuggling and unauthorized access or state changes. This issue is fixed in version 7.22.

osv:UBUNTU-CVE-2026-73256

mongoose

Fixed versions: Not specified

Complete source record
{
  "id": "32925b443bc36d7b3cef8916c453708463d3e512da7e89d7b5e92ea44176db77",
  "url": "https://osv.dev/vulnerability/UBUNTU-CVE-2026-73256",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "UBUNTU-CVE-2026-73256",
    "summary": "Mongoose is an embedded web server and network library. Prior to 7.22, a remote unauthenticated attacker can exploit an HTTP/1.0 reverse-proxy deployment by sending a request with Transfer-Encoding: chunked and conflicting framing. The http_cb() function in src/http.c tests hm.proto.len with an impossible greater-than-eight condition even though mg_http_parse() requires an eight-byte protocol string, so is_http_1_0 is never set. Mongoose consequently processes chunked encoding that an HTTP/1.0 proxy can ignore, enabling request smuggling and unauthorized access or state changes. This issue is fixed in version 7.22.",
    "evidence": "osv:UBUNTU-CVE-2026-73256",
    "products": [
      {
        "name": {
          "value": "mongoose",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [],
        "affected_versions": [
          {
            "value": "7.21+ds-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "7.21+ds-2",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "7.22+ds-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "7.23+ds-1",
            "evidence": "/affected/0/versions"
          }
        ]
      }
    ],
    "severity": "critical",
    "structured": {
      "id": "UBUNTU-CVE-2026-73256",
      "aliases": [
        "UBUNTU-CVE-2026-73256"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N"
        },
        {
          "type": "Ubuntu",
          "score": "medium"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                }
              ]
            }
          ],
          "package": {
            "name": "mongoose",
            "purl": "pkg:deb/ubuntu/mongoose?arch=source&distro=stonking",
            "ecosystem": "Ubuntu:26.10"
          },
          "versions": [
            "7.21+ds-1",
            "7.21+ds-2",
            "7.22+ds-1",
            "7.23+ds-1"
          ],
          "database_specific": {
            "source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-73256.json"
          },
          "ecosystem_specific": {
            "binaries": [
              {
                "binary_name": "mongoose-webserver-source",
                "binary_version": "7.23+ds-1"
              }
            ]
          }
        }
      ],
      "modified": "2026-10-17T13:01:01.762941207Z",
      "provider": "osv",
      "upstream": [
        "CVE-2026-73256"
      ],
      "references": [
        "https://ubuntu.com/security/CVE-2026-73256",
        "https://www.cve.org/CVERecord?id=CVE-2026-73256"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2026-73256",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 360891,
  "published_at": "2026-08-20T18:16:00+00:00"
}