High
Security advisory
GLPI is a free Asset and IT management software package. In versions prior to 9.5.6, a user who is logged in to GLPI can bypass Cross-Site Request Forgery (CSRF) protection in many places. This could allow a malicious actor to perform many actions on GLPI. This issue is fixed in version 9.5.6. There are no workarounds aside from upgrading.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-39209
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:53 UTC · Revision 1
Source evidence
GLPI is a free Asset and IT management software package. In versions prior to 9.5.6, a user who is logged in to GLPI can bypass Cross-Site Request Forgery (CSRF) protection in many places. This could allow a malicious actor to perform many actions on GLPI. This issue is fixed in version 9.5.6. There are no workarounds aside from upgrading.
osv:CVE-2021-39209
Complete source record
{
"id": "34ef0bac1da4b04ebd8082997aabc2bcef72081a447e65817f391070dec9ae8d",
"url": "https://osv.dev/vulnerability/CVE-2021-39209",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-39209",
"summary": "GLPI is a free Asset and IT management software package. In versions prior to 9.5.6, a user who is logged in to GLPI can bypass Cross-Site Request Forgery (CSRF) protection in many places. This could allow a malicious actor to perform many actions on GLPI. This issue is fixed in version 9.5.6. There are no workarounds aside from upgrading.",
"evidence": "osv:CVE-2021-39209",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2021-39209",
"aliases": [
"CVE-2021-39209",
"GHSA-5qpf-32w7-c56p"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/glpi-project/glpi",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "54502568d9d79c8695266e587a182dd85cf76f77"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "9.5.6"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "54502568d9d79c8695266e587a182dd85cf76f77"
}
],
"source": "REFERENCES_TAG",
"original_tag": "9.5.6"
}
]
}
}
],
"versions": [
"9.5.5",
"9.5.4",
"9.5.3",
"9.5.2",
"9.5.1",
"9.5.0",
"9.5.0-rc2",
"9.5.0-rc1",
"9.4.1.1",
"9.4.1",
"9.4.0",
"9.4.0-rc2",
"9.4.0-rc1",
"9.4.0-beta",
"9.3-beta",
"9.1",
"9.1-RC2",
"9.1-RC1",
"0.90",
"0.90-RC2",
"0.90-RC1",
"0.90-beta2",
"0.90-beta1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-39209.json"
}
}
],
"modified": "2026-10-20T10:54:53.573463580Z",
"provider": "osv",
"references": [
"https://github.com/glpi-project/glpi/releases/tag/9.5.6",
"https://github.com/glpi-project/glpi/security/advisories/GHSA-5qpf-32w7-c56p"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-39209",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 386383,
"published_at": "2021-09-15T16:15:07.27+00:00"
}