Security advisory
An attacker can exploit phpMyAdmin before 4.8.4 to leak the contents of a local file because of an error in the transformation feature. The attacker must have access to the phpMyAdmin Configuration Storage tables, although these can easily be created in any database to which the attacker has access. An attacker must have valid credentials to log in to phpMyAdmin; this vulnerability does not allow an attacker to circumvent the login system.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2018-19968
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 07:41 UTC · Revision 1
Source evidence
An attacker can exploit phpMyAdmin before 4.8.4 to leak the contents of a local file because of an error in the transformation feature. The attacker must have access to the phpMyAdmin Configuration Storage tables, although these can easily be created in any database to which the attacker has access. An attacker must have valid credentials to log in to phpMyAdmin; this vulnerability does not allow an attacker to circumvent the login system.
osv:CVE-2018-19968
Complete source record
{
"id": "87d91dc1bd4be24ab30c8af87e34878ee2d206dc121416c43d953e946cc76ee4",
"url": "https://osv.dev/vulnerability/CVE-2018-19968",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2018-19968",
"summary": "An attacker can exploit phpMyAdmin before 4.8.4 to leak the contents of a local file because of an error in the transformation feature. The attacker must have access to the phpMyAdmin Configuration Storage tables, although these can easily be created in any database to which the attacker has access. An attacker must have valid credentials to log in to phpMyAdmin; this vulnerability does not allow an attacker to circumvent the login system.",
"evidence": "osv:CVE-2018-19968",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2018-19968",
"aliases": [
"CVE-2018-19968",
"GHSA-xc97-r49q-cxgc"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/phpmyadmin/phpmyadmin",
"type": "GIT",
"events": [
{
"introduced": "6da64cc3b2ba4439574f914f51e161645375be96"
},
{
"fixed": "56ba19808f020fa8ac63366d450c3928564a91b8"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "4.0.0"
},
{
"fixed": "4.8.4"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-19968.json"
}
}
],
"modified": "2026-10-24T10:30:56.910083048Z",
"provider": "osv",
"references": [
"https://lists.debian.org/debian-lts-announce/2019/02/msg00003.html",
"https://security.gentoo.org/glsa/201904-16",
"https://www.phpmyadmin.net/security/PMASA-2018-6/"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "8.0"
},
{
"last_affected": "8.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2018-19968",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 438758,
"published_at": "2018-12-11T17:29:00.227+00:00"
}