Jetty's OpenId Revoked authentication allows one request
Jetty is a Java based web server and servlet engine. Versions 9.4.21 through 9.4.51, 10.0.15, and 11.0.15 are vulnerable to weak authentication. If a Jetty `OpenIdAuthenticator` uses the optional nested `LoginService`, and that `LoginService` decides to revoke an already authenticated user, then the current request will still treat the user as authenticated. The authentication is then cleared from the session and subsequent requests will not be treated as authenticated. So a request on a previously authenticated session could be allowed to bypass authentication after it had been rejected by the `LoginService`. This impacts usages of the jetty-openid which have configured a nested `LoginService` and where that `LoginService` will is capable of rejecting previously authenticated users. Versions 9.4.52, 10.0.16, and 11.0.16 have a patch for this issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-41900
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 16:01 UTC · Revision 1
Source evidence
Jetty's OpenId Revoked authentication allows one request
core-osv · Original sourcePublished 15 Sept 2023, 20:17 UTC
Jetty is a Java based web server and servlet engine. Versions 9.4.21 through 9.4.51, 10.0.15, and 11.0.15 are vulnerable to weak authentication. If a Jetty `OpenIdAuthenticator` uses the optional nested `LoginService`, and that `LoginService` decides to revoke an already authenticated user, then the current request will still treat the user as authenticated. The authentication is then cleared from the session and subsequent requests will not be treated as authenticated. So a request on a previously authenticated session could be allowed to bypass authentication after it had been rejected by the `LoginService`. This impacts usages of the jetty-openid which have configured a nested `LoginService` and where that `LoginService` will is capable of rejecting previously authenticated users. Versions 9.4.52, 10.0.16, and 11.0.16 have a patch for this issue.
osv:CVE-2023-41900
Complete source record
{
"id": "92c5428b79f2b2cbde5c344f82641ce99f5eed0171f929e84e71ccfb1405c897",
"url": "https://osv.dev/vulnerability/CVE-2023-41900",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Jetty's OpenId Revoked authentication allows one request",
"summary": "Jetty is a Java based web server and servlet engine. Versions 9.4.21 through 9.4.51, 10.0.15, and 11.0.15 are vulnerable to weak authentication. If a Jetty `OpenIdAuthenticator` uses the optional nested `LoginService`, and that `LoginService` decides to revoke an already authenticated user, then the current request will still treat the user as authenticated. The authentication is then cleared from the session and subsequent requests will not be treated as authenticated. So a request on a previously authenticated session could be allowed to bypass authentication after it had been rejected by the `LoginService`. This impacts usages of the jetty-openid which have configured a nested `LoginService` and where that `LoginService` will is capable of rejecting previously authenticated users. Versions 9.4.52, 10.0.16, and 11.0.16 have a patch for this issue.",
"evidence": "osv:CVE-2023-41900",
"products": [],
"severity": "low",
"structured": {
"id": "CVE-2023-41900",
"aliases": [
"CVE-2023-41900",
"GHSA-pwh8-58vv-vw48"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/jetty/jetty.project",
"type": "GIT",
"events": [
{
"introduced": "72970db61a2904371e1218a95a3bef5d79788c33"
},
{
"fixed": "abdcda73818a1a2c705da276edb0bf6581e7997e"
},
{
"introduced": "b9645a17373e4e9b7f30b6c0a07defcea2cb660b"
},
{
"fixed": "a2735a9ae9d1afc124974253f1e223e5678be1f4"
},
{
"introduced": "432f896d7a4555fcc81f38108757ea0aca8788e6"
},
{
"fixed": "bedff458c4dd1a716d59e17b8cb0d2042eeab291"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:eclipse:jetty:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "9.4.21"
},
{
"fixed": "9.4.52"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:eclipse:jetty:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "10.0.0"
},
{
"fixed": "10.0.16"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:eclipse:jetty:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "11.0.0"
},
{
"fixed": "11.0.16"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-41900.json"
}
}
],
"modified": "2026-10-28T02:30:37.041561186Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/41xxx/CVE-2023-41900.json",
"https://github.com/eclipse/jetty.project/security/advisories/GHSA-pwh8-58vv-vw48",
"https://nvd.nist.gov/vuln/detail/CVE-2023-41900",
"https://security.netapp.com/advisory/ntap-20231110-0004/",
"https://www.debian.org/security/2023/dsa-5507",
"https://github.com/eclipse/jetty.project/pull/9528",
"https://github.com/eclipse/jetty.project/pull/9660"
],
"provider_metadata": {
"cwe_ids": [
"CWE-1390"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/41xxx/CVE-2023-41900.json"
}
},
"related_cves": [
{
"value": "CVE-2023-41900",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 504432,
"published_at": "2023-09-15T20:17:42.201+00:00"
}