Skip to content
Heist/ feed
Back to feed
Critical

Apache Kylin prior to 4.0.2 allows command injection when the configuration overwrites function overwrites system parameters

Type: advisorySources: OSV

Kylin's cube designer function has a command injection vulnerability when overwriting system parameters in the configuration overwrites menu. RCE can be implemented by closing the single quotation marks around the parameter value of “-- conf=” to inject any operating system command into the command line parameters. This vulnerability affects Kylin 2 version 2.6.5 and earlier, Kylin 3 version 3.1.2 and earlier, and Kylin 4 version 4.0.1 and earlier.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2022-24697
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 14:21 UTC · Revision 1

Source evidence

Apache Kylin prior to 4.0.2 allows command injection when the configuration overwrites function overwrites system parameters

core-osv · Original source

Published 13 Oct 2022, 00:00 UTC

Kylin's cube designer function has a command injection vulnerability when overwriting system parameters in the configuration overwrites menu. RCE can be implemented by closing the single quotation marks around the parameter value of “-- conf=” to inject any operating system command into the command line parameters. This vulnerability affects Kylin 2 version 2.6.5 and earlier, Kylin 3 version 3.1.2 and earlier, and Kylin 4 version 4.0.1 and earlier.

osv:CVE-2022-24697
Complete source record
{
  "id": "357c6784b1af225c9411c65cbedfbbb6e7fbe143f9b0242263f09fcbb085e26f",
  "url": "https://osv.dev/vulnerability/CVE-2022-24697",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache Kylin prior to 4.0.2 allows command injection when the configuration overwrites function overwrites system parameters",
    "summary": "Kylin's cube designer function has a command injection vulnerability when overwriting system parameters in the configuration overwrites menu. RCE can be implemented by closing the single quotation marks around the parameter value of “-- conf=” to inject any operating system command into the command line parameters. This vulnerability affects Kylin 2 version 2.6.5 and earlier, Kylin 3 version 3.1.2 and earlier, and Kylin 4 version 4.0.1 and earlier.",
    "evidence": "osv:CVE-2022-24697",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2022-24697",
      "aliases": [
        "CVE-2022-24697",
        "GHSA-ppxx-m926-g569"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/kylin",
              "type": "GIT",
              "events": [
                {
                  "introduced": "375fd807c281d8c5deff0620747c806be2019782"
                },
                {
                  "fixed": "ddd5f8ecd4157b8f889b047e421dd9cfae7e1142"
                },
                {
                  "introduced": "c75242a9b55fd57a3a58d92a2dfa9f21cfe4eebc"
                },
                {
                  "last_affected": "f2639f670f82b39884a7c4d264d3b26dc938ae46"
                },
                {
                  "introduced": "aa6d582c0a96fdf31e85791f86850cfc00a7644f"
                },
                {
                  "last_affected": "337026c97d47d0325c3eeefe9fd2f2bebdb1eb18"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:kylin:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "2.0.0"
                      },
                      {
                        "fixed": "2.6.6"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "cpe": "cpe:2.3:a:apache:kylin:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "3.0.0"
                      },
                      {
                        "last_affected": "3.1.2"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "cpe": "cpe:2.3:a:apache:kylin:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "4.0.0"
                      },
                      {
                        "last_affected": "4.0.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-24697.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:29.288715660Z",
      "provider": "osv",
      "references": [
        "https://lists.apache.org/thread/07mnn9c7o314wrhrwjr10w9j5s82voj4",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/24xxx/CVE-2022-24697.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2022-24697"
      ],
      "provider_metadata": {
        "cna_assigner": "apache",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "Apache Kylin 2"
                  },
                  {
                    "fixed": "2.6.6"
                  },
                  {
                    "introduced": "Apache Kylin 3"
                  },
                  {
                    "last_affected": "3.1.2"
                  },
                  {
                    "introduced": "Apache Kylin 4"
                  },
                  {
                    "last_affected": "4.0.1"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/24xxx/CVE-2022-24697.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2022-24697",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 496325,
  "published_at": "2022-10-13T00:00:00+00:00"
}