HighFix available
snakeyaml — security advisory
The package org.yaml:snakeyaml from 0 and before 1.31 are vulnerable to Denial of Service (DoS) due missing to nested depth limitation for collections.
- Products
- snakeyaml
- Affected versions
- Not specified
- Fixed versions
- 1.31-1
- CVEs
- CVE-2022-25857
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:48 UTC · Revision 1
Source evidence
The package org.yaml:snakeyaml from 0 and before 1.31 are vulnerable to Denial of Service (DoS) due missing to nested depth limitation for collections.
osv:DEBIAN-CVE-2022-25857
snakeyaml
Fixed versions: 1.31-1
snakeyaml
Fixed versions: 1.31-1
snakeyaml
Fixed versions: 1.31-1
Complete source record
{
"id": "5fcb3e3ede8508d61bafa33e47f498471df726b540e91a645247841d90f539d7",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-25857",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-25857",
"summary": "The package org.yaml:snakeyaml from 0 and before 1.31 are vulnerable to Denial of Service (DoS) due missing to nested depth limitation for collections.",
"evidence": "osv:DEBIAN-CVE-2022-25857",
"products": [
{
"name": {
"value": "snakeyaml",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.31-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "snakeyaml",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.31-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "snakeyaml",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.31-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-25857",
"aliases": [
"DEBIAN-CVE-2022-25857"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.31-1"
}
]
}
],
"package": {
"name": "snakeyaml",
"purl": "pkg:deb/debian/snakeyaml?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-25857.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.31-1"
}
]
}
],
"package": {
"name": "snakeyaml",
"purl": "pkg:deb/debian/snakeyaml?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-25857.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.31-1"
}
]
}
],
"package": {
"name": "snakeyaml",
"purl": "pkg:deb/debian/snakeyaml?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-25857.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:21.378277971Z",
"provider": "osv",
"upstream": [
"CVE-2022-25857"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-25857"
]
},
"related_cves": [
{
"value": "CVE-2022-25857",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 323376,
"published_at": "2022-08-30T05:15:07.667+00:00"
}