Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2017-1000479

pfSense versions 2.4.1 and lower are vulnerable to clickjacking attacks in the CSRF error page resulting in privileged execution of arbitrary code, because the error detection occurs before an X-Frame-Options header is set. This is fixed in 2.4.2-RELEASE. OPNsense, a 2015 fork of pfSense, was not vulnerable since version 16.1.16 released on June 06, 2016. The unprotected web form was removed from the code during an internal security audit under "possibly insecure" suspicions.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2017-1000479
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 09:41 UTC · Revision 1

Source evidence

CVE-2017-1000479

core-osv · Original source

Published 3 Jan 2018, 18:29 UTC

pfSense versions 2.4.1 and lower are vulnerable to clickjacking attacks in the CSRF error page resulting in privileged execution of arbitrary code, because the error detection occurs before an X-Frame-Options header is set. This is fixed in 2.4.2-RELEASE. OPNsense, a 2015 fork of pfSense, was not vulnerable since version 16.1.16 released on June 06, 2016. The unprotected web form was removed from the code during an internal security audit under "possibly insecure" suspicions.

osv:CVE-2017-1000479
Complete source record
{
  "id": "6e8dfcaf5c66ac301ef990d8449d5e3e65ad8555a1c3171162705c19dba9b55a",
  "url": "https://osv.dev/vulnerability/CVE-2017-1000479",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2017-1000479",
    "summary": "pfSense versions 2.4.1 and lower are vulnerable to clickjacking attacks in the CSRF error page resulting in privileged execution of arbitrary code, because the error detection occurs before an X-Frame-Options header is set. This is fixed in 2.4.2-RELEASE. OPNsense, a 2015 fork of pfSense, was not vulnerable since version 16.1.16 released on June 06, 2016. The unprotected web form was removed from the code during an internal security audit under \"possibly insecure\" suspicions.",
    "evidence": "osv:CVE-2017-1000479",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2017-1000479",
      "aliases": [
        "CVE-2017-1000479"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/opnsense/core",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "f4861262989cef00c6918454a8295df4ff04e5e8"
                },
                {
                  "fixed": "d218b225"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:opnsense_project:opnsense:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "16.1.16"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "d218b225"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "16.1.15",
            "16.1.14",
            "16.1.13",
            "16.1.12",
            "16.1.11",
            "16.1.10",
            "16.1.9",
            "16.1.8",
            "16.1.7",
            "16.1.6",
            "16.1.5",
            "16.1.4",
            "16.1.3",
            "16.1.2",
            "16.1.1",
            "16.1",
            "15.7",
            "15.1.12",
            "15.1.11.4",
            "15.1.11.3",
            "15.1.11.2",
            "15.1.11.1",
            "15.1.11",
            "15.1.10.2",
            "15.1.10",
            "15.1.9.2",
            "15.1.9.1",
            "15.1.9",
            "15.1.8.4",
            "15.1.8.3",
            "15.1.8.2",
            "15.1.8.1",
            "15.1.8",
            "15.1.7.2",
            "15.1.7.1",
            "15.1.7",
            "15.1.6.1",
            "15.1.6",
            "15.1.5",
            "15.1.4",
            "15.1.3",
            "15.1.2",
            "15.1.1",
            "15.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-1000479.json"
          }
        },
        {
          "ranges": [
            {
              "repo": "https://github.com/pfsense/pfsense",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "last_affected": "488c6e228ac9733bee85cb14e0879a591bf2b6b7"
                },
                {
                  "fixed": "386d89b07"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:netgate:pfsense:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "last_affected": "2.4.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "386d89b07"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v2.4.1",
            "RELENG_2_2_BETA",
            "Root_RELENG_1_2"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-1000479.json"
          }
        }
      ],
      "modified": "2026-10-20T10:47:34.849937202Z",
      "provider": "osv",
      "references": [
        "https://www.netgate.com/blog/pfsense-2-4-2-release-p1-and-2-3-5-release-p1-now-available.html",
        "https://doc.pfsense.org/index.php/2.4.2_New_Features_and_Changes",
        "https://github.com/opnsense/core/commit/d218b225",
        "https://github.com/pfsense/pfsense/commit/386d89b07",
        "https://www.securify.nl/en/advisory/SFY20171101/clickjacking-vulnerability-in-csrf-error-page-pfsense.html"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2017-1000479",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 379531,
  "published_at": "2018-01-03T18:29:00.323+00:00"
}