Medium
Security advisory
Before WordPress 4.9.5, the version string was not escaped in the get_the_generator function, and could lead to XSS in a generator tag.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2018-10102
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 08:33 UTC · Revision 1
Source evidence
Before WordPress 4.9.5, the version string was not escaped in the get_the_generator function, and could lead to XSS in a generator tag.
osv:CVE-2018-10102
Complete source record
{
"id": "3953e71bf524bd9347f407a0ea5954ccb51c679440eac717908fc9cf8b2b03d8",
"url": "https://osv.dev/vulnerability/CVE-2018-10102",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2018-10102",
"summary": "Before WordPress 4.9.5, the version string was not escaped in the get_the_generator function, and could lead to XSS in a generator tag.",
"evidence": "osv:CVE-2018-10102",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2018-10102",
"aliases": [
"CVE-2018-10102"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/wordpress/wordpress",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "a4b0b219b23fe22eb6168391385b12052cd25e3e"
},
{
"fixed": "31a4369366d6b8ce30045d4c838de2412c77850d"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "4.9.5"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "31a4369366d6b8ce30045d4c838de2412c77850d"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-10102.json"
}
},
{
"ranges": [
{
"repo": "https://github.com/wordpress/wordpress-develop",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "48db4299dde9b49a9ba731102dbb555904e49070"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "4.9.5"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-10102.json"
}
}
],
"modified": "2026-10-24T10:47:36.800031291Z",
"provider": "osv",
"references": [
"https://codex.wordpress.org/Version_4.9.5",
"https://lists.debian.org/debian-lts-announce/2018/04/msg00031.html",
"https://wordpress.org/news/2018/04/wordpress-4-9-5-security-and-maintenance-release/",
"https://wpvulndb.com/vulnerabilities/9055",
"https://www.debian.org/security/2018/dsa-4193",
"https://core.trac.wordpress.org/changeset/42893",
"https://github.com/WordPress/WordPress/commit/31a4369366d6b8ce30045d4c838de2412c77850d"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "8.0"
},
{
"last_affected": "8.0"
},
{
"introduced": "9.0"
},
{
"last_affected": "9.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2018-10102",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 441392,
"published_at": "2018-04-16T09:58:09.713+00:00"
}