angular.js — security advisory
The package angular after 1.7.0 are vulnerable to Regular Expression Denial of Service (ReDoS) by providing a custom locale rule that makes it possible to assign the parameter in posPre: ' '.repeat() of NUMBER_FORMATS.PATTERNS[1].posPre with a very high value. **Note:** 1) This package has been deprecated and is no longer maintained. 2) The vulnerable versions are 1.7.0 and higher.
- Products
- angular.js
- Affected versions
- 1.8.3-1, 1.8.3-1+deb12u1~deb11u1
- Fixed versions
- 1.8.3-1+deb12u1, 1.8.3-2
- CVEs
- CVE-2022-25844
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:43 UTC · Revision 1
Source evidence
The package angular after 1.7.0 are vulnerable to Regular Expression Denial of Service (ReDoS) by providing a custom locale rule that makes it possible to assign the parameter in posPre: ' '.repeat() of NUMBER_FORMATS.PATTERNS[1].posPre with a very high value. **Note:** 1) This package has been deprecated and is no longer maintained. 2) The vulnerable versions are 1.7.0 and higher.
osv:DEBIAN-CVE-2022-25844
angular.js
Fixed versions: 1.8.3-1+deb12u1
angular.js
Fixed versions: 1.8.3-2
Complete source record
{
"id": "4c267287dc4ca21a9f1bf22d84558d937f859cdc58dd80b53877870251c7f429",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-25844",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-25844",
"summary": "The package angular after 1.7.0 are vulnerable to Regular Expression Denial of Service (ReDoS) by providing a custom locale rule that makes it possible to assign the parameter in posPre: ' '.repeat() of NUMBER_FORMATS.PATTERNS[1].posPre with a very high value. **Note:** 1) This package has been deprecated and is no longer maintained. 2) The vulnerable versions are 1.7.0 and higher.",
"evidence": "osv:DEBIAN-CVE-2022-25844",
"products": [
{
"name": {
"value": "angular.js",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.8.3-1+deb12u1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "1.8.3-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.3-1+deb12u1~deb11u1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "angular.js",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.8.3-2",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-25844",
"aliases": [
"DEBIAN-CVE-2022-25844"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.8.3-1+deb12u1"
}
]
}
],
"package": {
"name": "angular.js",
"purl": "pkg:deb/debian/angular.js?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"1.8.3-1",
"1.8.3-1+deb12u1~deb11u1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-25844.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.8.3-2"
}
]
}
],
"package": {
"name": "angular.js",
"purl": "pkg:deb/debian/angular.js?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-25844.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:01:45.997064126Z",
"provider": "osv",
"upstream": [
"CVE-2022-25844"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-25844"
]
},
"related_cves": [
{
"value": "CVE-2022-25844",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 323130,
"published_at": "2022-05-01T16:15:08.767+00:00"
}