Low
Ampache Stored XSS
Type: advisorySources: OSV
Ampache is a web based audio/video streaming application and file manager. Stored Cross Site Scripting (XSS) vulnerability in ampache before v6.3.1 allows a remote attacker to execute code via a crafted payload to serval parameters in the post request of /preferences.php?action=admin_update_preferences. This vulnerability is fixed in 6.3.1.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-28853
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 6 Nov 2026, 04:28 UTC · Revision 1
Source evidence
Ampache is a web based audio/video streaming application and file manager. Stored Cross Site Scripting (XSS) vulnerability in ampache before v6.3.1 allows a remote attacker to execute code via a crafted payload to serval parameters in the post request of /preferences.php?action=admin_update_preferences. This vulnerability is fixed in 6.3.1.
osv:CVE-2024-28853
Complete source record
{
"id": "0f167730866d8ae6e7be697f3580b462ffa3a69ad23f7416acb52f4c6467387d",
"url": "https://osv.dev/vulnerability/CVE-2024-28853",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Ampache Stored XSS",
"summary": "Ampache is a web based audio/video streaming application and file manager. Stored Cross Site Scripting (XSS) vulnerability in ampache before v6.3.1 allows a remote attacker to execute code via a crafted payload to serval parameters in the post request of /preferences.php?action=admin_update_preferences. This vulnerability is fixed in 6.3.1.",
"evidence": "osv:CVE-2024-28853",
"products": [],
"severity": "low",
"structured": {
"id": "CVE-2024-28853",
"aliases": [
"CVE-2024-28853",
"GHSA-prw2-7cr3-5mx8"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/ampache/ampache",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "eae313e4e63f0a9b7b14db4d0f39d303a0fee073"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "6.3.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"cpe": "cpe:2.3:a:ampache:ampache:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "6.3.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"6.3.0",
"6.2.1",
"6.2.0",
"6.1.0",
"6.0.3",
"6.0.2",
"6.0.1",
"6.0.0",
"5.6.1",
"5.6.0",
"5.5.7",
"5.5.6",
"5.5.5",
"5.5.4",
"5.5.3",
"5.5.2",
"5.5.1",
"5.5.0",
"5.4.1",
"5.4.0",
"5.3.3",
"5.3.2",
"5.3.1",
"5.3.0",
"5.2.1",
"5.2.0",
"5.1.1",
"5.1.0",
"5.0.0",
"4.4.1",
"4.4.0",
"4.3.0",
"4.2.6",
"4.2.5",
"4.2.4",
"4.2.3",
"4.2.2",
"4.2.1",
"4.2.0",
"3.8.9",
"3.8.0",
"3.7.0",
"3.6-alpha6",
"3.6-alpha5",
"3.6-alpha4",
"3.6-alpha3",
"3.6-alpha2",
"3.6-alpha1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-28853.json"
}
}
],
"modified": "2026-10-28T02:30:46.386653356Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/28xxx/CVE-2024-28853.json",
"https://github.com/ampache/ampache/security/advisories/GHSA-prw2-7cr3-5mx8",
"https://nvd.nist.gov/vuln/detail/CVE-2024-28853"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/28xxx/CVE-2024-28853.json"
}
},
"related_cves": [
{
"value": "CVE-2024-28853",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 514614,
"published_at": "2024-03-27T13:17:56.679+00:00"
}