Skip to content
Heist/ feed
Back to feed
UnratedFix available

rails — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2011-0447

Ruby on Rails 2.1.x, 2.2.x, and 2.3.x before 2.3.11, and 3.x before 3.0.4, does not properly validate HTTP requests that contain an X-Requested-With header, which makes it easier for remote attackers to conduct cross-site request forgery (CSRF) attacks via forged (1) AJAX or (2) API requests that leverage "combinations of browser plugins and HTTP redirects," a related issue to CVE-2011-0696.

Products
rails
Affected versions
Not specified
Fixed versions
2.3.11-0.1
CVEs
CVE-2011-0447
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 23:24 UTC · Revision 1

Source evidence

DEBIAN-CVE-2011-0447

core-osv · Original source

Published 14 Feb 2011, 21:00 UTC

Ruby on Rails 2.1.x, 2.2.x, and 2.3.x before 2.3.11, and 3.x before 3.0.4, does not properly validate HTTP requests that contain an X-Requested-With header, which makes it easier for remote attackers to conduct cross-site request forgery (CSRF) attacks via forged (1) AJAX or (2) API requests that leverage "combinations of browser plugins and HTTP redirects," a related issue to CVE-2011-0696.

osv:DEBIAN-CVE-2011-0447

rails

Fixed versions: 2.3.11-0.1

rails

Fixed versions: 2.3.11-0.1

rails

Fixed versions: 2.3.11-0.1

Complete source record
{
  "id": "4d134aa3118b86bc66932059d384914d6887834706efb450766dfe4a920ba80e",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2011-0447",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2011-0447",
    "summary": "Ruby on Rails 2.1.x, 2.2.x, and 2.3.x before 2.3.11, and 3.x before 3.0.4, does not properly validate HTTP requests that contain an X-Requested-With header, which makes it easier for remote attackers to conduct cross-site request forgery (CSRF) attacks via forged (1) AJAX or (2) API requests that leverage \"combinations of browser plugins and HTTP redirects,\" a related issue to CVE-2011-0696.",
    "evidence": "osv:DEBIAN-CVE-2011-0447",
    "products": [
      {
        "name": {
          "value": "rails",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.3.11-0.1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "rails",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.3.11-0.1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "rails",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.3.11-0.1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "unknown",
    "structured": {
      "id": "DEBIAN-CVE-2011-0447",
      "aliases": [
        "DEBIAN-CVE-2011-0447"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.3.11-0.1"
                }
              ]
            }
          ],
          "package": {
            "name": "rails",
            "purl": "pkg:deb/debian/rails?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-0447.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.3.11-0.1"
                }
              ]
            }
          ],
          "package": {
            "name": "rails",
            "purl": "pkg:deb/debian/rails?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-0447.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.3.11-0.1"
                }
              ]
            }
          ],
          "package": {
            "name": "rails",
            "purl": "pkg:deb/debian/rails?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-0447.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T17:47:42.494015881Z",
      "provider": "osv",
      "upstream": [
        "CVE-2011-0447"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2011-0447"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2011-0447",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "core-osv",
  "document_id": 418477,
  "published_at": "2011-02-14T21:00:03.087+00:00"
}