Skip to content
Heist/ feed
Back to feed
HighFix available

libyaml-perl — security advisory

Type: advisorySources: OSVAdvisory ID: UBUNTU-CVE-2019-25777

YAML versions before 1.27_001 for Perl allow a loaded perl/glob document to replace any package variable, which can lead to arbitrary code execution. A perl/glob document names a package and a symbol, and supplies the value assigned to it. Nothing restricts the name, so the target can be @INC or YAML's own load options. A perl/glob document that sets $YAML::LoadCode or $YAML::UseCode turns on code loading, which is off by default, for every later Load() in the process. A perl/code document is then passed to a string eval, so an attacker who supplies two documents to separate Load() calls in one process can execute arbitrary Perl code.

Products
libyaml-perl
Affected versions
1.13-1, 1.15-1, 1.21-1, 1.24-1
Fixed versions
1.15-1ubuntu0.1~esm1, 1.24-1ubuntu0.1~esm1
CVEs
CVE-2019-25777
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 12:12 UTC · Revision 1

Source evidence

UBUNTU-CVE-2019-25777

core-osv · Original source

Published 5 Oct 2026, 07:16 UTC

YAML versions before 1.27_001 for Perl allow a loaded perl/glob document to replace any package variable, which can lead to arbitrary code execution. A perl/glob document names a package and a symbol, and supplies the value assigned to it. Nothing restricts the name, so the target can be @INC or YAML's own load options. A perl/glob document that sets $YAML::LoadCode or $YAML::UseCode turns on code loading, which is off by default, for every later Load() in the process. A perl/code document is then passed to a string eval, so an attacker who supplies two documents to separate Load() calls in one process can execute arbitrary Perl code.

osv:UBUNTU-CVE-2019-25777

libyaml-perl

Fixed versions: 1.15-1ubuntu0.1~esm1

libyaml-perl

Fixed versions: 1.24-1ubuntu0.1~esm1

Complete source record
{
  "id": "9ec6a33451354f316f139c347147955bf88122a0cbb184c0b1ec84d5446c050f",
  "url": "https://osv.dev/vulnerability/UBUNTU-CVE-2019-25777",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "UBUNTU-CVE-2019-25777",
    "summary": "YAML versions before 1.27_001 for Perl allow a loaded perl/glob document to replace any package variable, which can lead to arbitrary code execution. A perl/glob document names a package and a symbol, and supplies the value assigned to it. Nothing restricts the name, so the target can be @INC or YAML's own load options. A perl/glob document that sets $YAML::LoadCode or $YAML::UseCode turns on code loading, which is off by default, for every later Load() in the process. A perl/code document is then passed to a string eval, so an attacker who supplies two documents to separate Load() calls in one process can execute arbitrary Perl code.",
    "evidence": "osv:UBUNTU-CVE-2019-25777",
    "products": [
      {
        "name": {
          "value": "libyaml-perl",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.15-1ubuntu0.1~esm1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": [
          {
            "value": "1.13-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "1.15-1",
            "evidence": "/affected/0/versions"
          }
        ]
      },
      {
        "name": {
          "value": "libyaml-perl",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.24-1ubuntu0.1~esm1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": [
          {
            "value": "1.21-1",
            "evidence": "/affected/1/versions"
          },
          {
            "value": "1.24-1",
            "evidence": "/affected/1/versions"
          }
        ]
      }
    ],
    "severity": "high",
    "structured": {
      "id": "UBUNTU-CVE-2019-25777",
      "aliases": [
        "UBUNTU-CVE-2019-25777"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L"
        },
        {
          "type": "Ubuntu",
          "score": "medium"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.15-1ubuntu0.1~esm1"
                }
              ]
            }
          ],
          "package": {
            "name": "libyaml-perl",
            "purl": "pkg:deb/ubuntu/libyaml-perl?arch=source&distro=esm-infra-legacy%2Fxenial",
            "ecosystem": "Ubuntu:Pro:16.04:LTS"
          },
          "versions": [
            "1.13-1",
            "1.15-1"
          ],
          "database_specific": {
            "source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2019/UBUNTU-CVE-2019-25777.json"
          },
          "ecosystem_specific": {
            "binaries": [
              {
                "binary_name": "libyaml-perl",
                "binary_version": "1.15-1ubuntu0.1~esm1"
              }
            ],
            "availability": "Available with Ubuntu Pro with Legacy support add-on: https://ubuntu.com/pro"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.24-1ubuntu0.1~esm1"
                }
              ]
            }
          ],
          "package": {
            "name": "libyaml-perl",
            "purl": "pkg:deb/ubuntu/libyaml-perl?arch=source&distro=esm-infra%2Fbionic",
            "ecosystem": "Ubuntu:Pro:18.04:LTS"
          },
          "versions": [
            "1.21-1",
            "1.24-1"
          ],
          "database_specific": {
            "source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2019/UBUNTU-CVE-2019-25777.json"
          },
          "ecosystem_specific": {
            "binaries": [
              {
                "binary_name": "libyaml-perl",
                "binary_version": "1.24-1ubuntu0.1~esm1"
              }
            ],
            "availability": "Available with Ubuntu Pro (Infra-only): https://ubuntu.com/pro"
          }
        }
      ],
      "modified": "2026-10-14T11:45:06.688699843Z",
      "provider": "osv",
      "upstream": [
        "CVE-2019-25777"
      ],
      "references": [
        "https://ubuntu.com/security/CVE-2019-25777",
        "https://www.cve.org/CVERecord?id=CVE-2019-25777",
        "https://www.openwall.com/lists/oss-security/2026/10/05/7",
        "https://ubuntu.com/security/notices/USN-8925-1"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2019-25777",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 316281,
  "published_at": "2026-10-05T07:16:00+00:00"
}