MediumFix available
node-postcss — security advisory
The package postcss from 7.0.0 and before 8.2.10 are vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.
- Products
- node-postcss
- Affected versions
- Not specified
- Fixed versions
- 8.2.1+~cs5.3.23-6
- CVEs
- CVE-2021-23368
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 00:42 UTC · Revision 1
Source evidence
The package postcss from 7.0.0 and before 8.2.10 are vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.
osv:DEBIAN-CVE-2021-23368
node-postcss
Fixed versions: 8.2.1+~cs5.3.23-6
node-postcss
Fixed versions: 8.2.1+~cs5.3.23-6
node-postcss
Fixed versions: 8.2.1+~cs5.3.23-6
Complete source record
{
"id": "fb668d2a5f6deda9310e5bfb31f8ca8b5f3a7c330f200c9d79685400af2c1747",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-23368",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2021-23368",
"summary": "The package postcss from 7.0.0 and before 8.2.10 are vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.",
"evidence": "osv:DEBIAN-CVE-2021-23368",
"products": [
{
"name": {
"value": "node-postcss",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "8.2.1+~cs5.3.23-6",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "node-postcss",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "8.2.1+~cs5.3.23-6",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "node-postcss",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "8.2.1+~cs5.3.23-6",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2021-23368",
"aliases": [
"DEBIAN-CVE-2021-23368"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "8.2.1+~cs5.3.23-6"
}
]
}
],
"package": {
"name": "node-postcss",
"purl": "pkg:deb/debian/node-postcss?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-23368.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "8.2.1+~cs5.3.23-6"
}
]
}
],
"package": {
"name": "node-postcss",
"purl": "pkg:deb/debian/node-postcss?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-23368.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "8.2.1+~cs5.3.23-6"
}
]
}
],
"package": {
"name": "node-postcss",
"purl": "pkg:deb/debian/node-postcss?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-23368.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:03:37.005852175Z",
"provider": "osv",
"upstream": [
"CVE-2021-23368"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2021-23368"
]
},
"related_cves": [
{
"value": "CVE-2021-23368",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 422007,
"published_at": "2021-04-12T14:15:14.257+00:00"
}