Apache Tomcat Connectors: mod_jk: local users can view and modify configuration
Incorrect Default Permissions vulnerability in Apache Tomcat Connectors allows local users to view and modify shared memory containing mod_jk configuration which may lead to information disclosure and/or denial of service. This issue affects Apache Tomcat Connectors: from 1.2.9-beta through 1.2.49. Only mod_jk on Unix like systems is affected. Neither the ISAPI redirector nor mod_jk on Windows is affected. Users are recommended to upgrade to version 1.2.50, which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-46544
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 18:25 UTC · Revision 1
Source evidence
Apache Tomcat Connectors: mod_jk: local users can view and modify configuration
core-osv · Original sourcePublished 23 Sept 2024, 10:43 UTC
Incorrect Default Permissions vulnerability in Apache Tomcat Connectors allows local users to view and modify shared memory containing mod_jk configuration which may lead to information disclosure and/or denial of service. This issue affects Apache Tomcat Connectors: from 1.2.9-beta through 1.2.49. Only mod_jk on Unix like systems is affected. Neither the ISAPI redirector nor mod_jk on Windows is affected. Users are recommended to upgrade to version 1.2.50, which fixes the issue.
osv:CVE-2024-46544
Complete source record
{
"id": "712493a9033d9dd4846bdbdd653a9bc8e94a9e6f6348bb094bb02ee788dd4c83",
"url": "https://osv.dev/vulnerability/CVE-2024-46544",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache Tomcat Connectors: mod_jk: local users can view and modify configuration",
"summary": "Incorrect Default Permissions vulnerability in Apache Tomcat Connectors allows local users to view and modify shared memory containing mod_jk configuration which may lead to information disclosure and/or denial of service. This issue affects Apache Tomcat Connectors: from 1.2.9-beta through 1.2.49. Only mod_jk on Unix like systems is affected. Neither the ISAPI redirector nor mod_jk on Windows is affected. Users are recommended to upgrade to version 1.2.50, which fixes the issue.",
"evidence": "osv:CVE-2024-46544",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-46544",
"aliases": [
"CVE-2024-46544"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/tomcat-connectors",
"type": "GIT",
"events": [
{
"introduced": "f48d0853cc16db3a62e27f0a1bf3522b8044906f"
},
{
"fixed": "9612683ac09ebb06aca9ad25cdd7274152c6d031"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:tomcat_connectors:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "1.2.9"
},
{
"fixed": "1.2.50"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-46544.json"
}
}
],
"modified": "2026-10-28T02:30:22.039871593Z",
"provider": "osv",
"references": [
"https://lists.debian.org/debian-lts-announce/2024/10/msg00010.html",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/46xxx/CVE-2024-46544.json",
"https://lists.apache.org/thread/q1gp7cc38hs1r8gj8gfnopwznd5fpr4d",
"https://nvd.nist.gov/vuln/detail/CVE-2024-46544"
],
"provider_metadata": {
"cwe_ids": [
"CWE-276"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "1.2.9-beta"
},
{
"last_affected": "1.2.49"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/46xxx/CVE-2024-46544.json"
}
},
"related_cves": [
{
"value": "CVE-2024-46544",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 488349,
"published_at": "2024-09-23T10:43:57.123+00:00"
}