nltk — security advisory
In nltk/nltk versions 3.9.3 and earlier, five Stanford interface classes (StanfordPOSTagger, StanfordNERTagger, StanfordParser, StanfordDependencyParser, and StanfordNeuralDependencyParser) are vulnerable to untrusted JAR code execution. These classes accept user-controllable JAR paths and execute them via the `java()` function, which invokes `subprocess.Popen()` without integrity verification. This vulnerability is identical to CVE-2026-0848, which was fixed for StanfordSegmenter by adding SHA256 verification. However, the fix was not applied to these additional classes, leaving them susceptible to arbitrary code execution when loading untrusted JAR files.
- Products
- nltk
- Affected versions
- 3.10.0-1, 3.10.1-1, 3.10.3-1, 3.8-1, 3.8.1-1, 3.9.1-1, 3.9.1-2, 3.9.2-1, 3.9.3-1
- Fixed versions
- 3.10.3-1
- CVEs
- CVE-2026-12252
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 12:14 UTC · Revision 2
Source evidence
In nltk/nltk versions 3.9.3 and earlier, five Stanford interface classes (StanfordPOSTagger, StanfordNERTagger, StanfordParser, StanfordDependencyParser, and StanfordNeuralDependencyParser) are vulnerable to untrusted JAR code execution. These classes accept user-controllable JAR paths and execute them via the `java()` function, which invokes `subprocess.Popen()` without integrity verification. This vulnerability is identical to CVE-2026-0848, which was fixed for StanfordSegmenter by adding SHA256 verification. However, the fix was not applied to these additional classes, leaving them susceptible to arbitrary code execution when loading untrusted JAR files.
osv:DEBIAN-CVE-2026-12252
nltk
Fixed versions: Not specified
nltk
Fixed versions: Not specified
nltk
Fixed versions: 3.10.3-1
Complete source record
{
"id": "ad530a1d5debadf507e89474b81d0a209da2cc98c68fd1ef6a2987178bb517b0",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-12252",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-12252",
"summary": "In nltk/nltk versions 3.9.3 and earlier, five Stanford interface classes (StanfordPOSTagger, StanfordNERTagger, StanfordParser, StanfordDependencyParser, and StanfordNeuralDependencyParser) are vulnerable to untrusted JAR code execution. These classes accept user-controllable JAR paths and execute them via the `java()` function, which invokes `subprocess.Popen()` without integrity verification. This vulnerability is identical to CVE-2026-0848, which was fixed for StanfordSegmenter by adding SHA256 verification. However, the fix was not applied to these additional classes, leaving them susceptible to arbitrary code execution when loading untrusted JAR files.",
"evidence": "osv:DEBIAN-CVE-2026-12252",
"products": [
{
"name": {
"value": "nltk",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "3.10.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.10.1-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.10.3-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.8-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.8.1-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.9.1-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.9.1-2",
"evidence": "/affected/0/versions"
},
{
"value": "3.9.2-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.9.3-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "nltk",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "3.10.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "3.10.1-1",
"evidence": "/affected/1/versions"
},
{
"value": "3.10.3-1",
"evidence": "/affected/1/versions"
},
{
"value": "3.9.1-2",
"evidence": "/affected/1/versions"
},
{
"value": "3.9.2-1",
"evidence": "/affected/1/versions"
},
{
"value": "3.9.3-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "nltk",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.10.3-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "3.10.0-1",
"evidence": "/affected/2/versions"
},
{
"value": "3.10.1-1",
"evidence": "/affected/2/versions"
},
{
"value": "3.9.1-2",
"evidence": "/affected/2/versions"
},
{
"value": "3.9.2-1",
"evidence": "/affected/2/versions"
},
{
"value": "3.9.3-1",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2026-12252",
"aliases": [
"DEBIAN-CVE-2026-12252"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "nltk",
"purl": "pkg:deb/debian/nltk?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"3.10.0-1",
"3.10.1-1",
"3.10.3-1",
"3.8-1",
"3.8.1-1",
"3.9.1-1",
"3.9.1-2",
"3.9.2-1",
"3.9.3-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-12252.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "nltk",
"purl": "pkg:deb/debian/nltk?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"3.10.0-1",
"3.10.1-1",
"3.10.3-1",
"3.9.1-2",
"3.9.2-1",
"3.9.3-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-12252.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.10.3-1"
}
]
}
],
"package": {
"name": "nltk",
"purl": "pkg:deb/debian/nltk?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"3.10.0-1",
"3.10.1-1",
"3.9.1-2",
"3.9.2-1",
"3.9.3-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-12252.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T11:47:29.404886261Z",
"provider": "osv",
"upstream": [
"CVE-2026-12252"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-12252"
]
},
"related_cves": [
{
"value": "CVE-2026-12252",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 450717,
"published_at": "2026-07-04T02:16:23.603+00:00"
}