Medium
Security advisory
The Admin Columns WordPress plugin before 4.3 and Admin Columns Pro WordPress plugin before 5.5.1 do not sanitise and escape its Label settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-24366
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:41 UTC · Revision 1
Source evidence
The Admin Columns WordPress plugin before 4.3 and Admin Columns Pro WordPress plugin before 5.5.1 do not sanitise and escape its Label settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
osv:CVE-2021-24366
Complete source record
{
"id": "12e81092a70313ea94222905b54ce51241baa15144b35bc78d194f1b00e00462",
"url": "https://osv.dev/vulnerability/CVE-2021-24366",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-24366",
"summary": "The Admin Columns WordPress plugin before 4.3 and Admin Columns Pro WordPress plugin before 5.5.1 do not sanitise and escape its Label settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)",
"evidence": "osv:CVE-2021-24366",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2021-24366",
"aliases": [
"CVE-2021-24366"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/codepress/admin-columns",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "23fc67a4aae9461c1945ef16f31708988deb6bf9"
},
{
"fixed": "b45571ed21d574d13687213a5002e0c68e4442c7"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:admincolumns:admin_columns:*:*:*:*:free:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "4.3"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "b45571ed21d574d13687213a5002e0c68e4442c7"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"4.2.7",
"4.2.6",
"4.2.5",
"4.2.4",
"4.2.3",
"4.2.2",
"4.2.1",
"4.2",
"4.1.9",
"4.1.8",
"4.1.7",
"4.1.6",
"4.1.5",
"4.1.4",
"4.1.2",
"4.1.1",
"4.1.0",
"4.0.3",
"4.0.2",
"4.0.1",
"4.0",
"3.4.8",
"3.4.7",
"3.4.6",
"3.4.5",
"3.4.4",
"3.4.3",
"3.4.2",
"3.4.1",
"3.4",
"3.3.1",
"3.3",
"3.2.7",
"3.2.6",
"3.2.5",
"3.2.4",
"3.2.3",
"3.2.2",
"3.2.1",
"3.2",
"3.1.10",
"3.1.9",
"3.1.8",
"3.1.7",
"3.1.6",
"3.1.5",
"3.1.4",
"3.1.3",
"3.1.2",
"3.1.1",
"3.0.7",
"3.0.6",
"3.0.5",
"3.0.1",
"3.0",
"2.5.6.3",
"2.5.5",
"2.5.3",
"2.5.1",
"2.5",
"2.4.9",
"2.4.8",
"2.4.7",
"2.4.2",
"2.4.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-24366.json"
}
}
],
"modified": "2026-10-20T10:54:33.012404339Z",
"provider": "osv",
"references": [
"https://github.com/codepress/admin-columns/commit/b45571ed21d574d13687213a5002e0c68e4442c7",
"https://wpscan.com/vulnerability/05427156-4d5c-4aeb-add8-1c574fda5c28",
"https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-24366"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:a:admincolumns:admin_columns:*:*:*:*:pro:wordpress:*:*"
],
"vendor_product": "admincolumns:admin_columns",
"extracted_events": [
{
"range": [
{
"fixed": "5.5.1"
}
],
"source": "CPE_RANGE"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2021-24366",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 385553,
"published_at": "2021-06-21T20:15:08.49+00:00"
}