Skip to content
Heist/ feed
Back to feed
HighFix available

caddy — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2026-52845

Caddy is an extensible server platform that uses TLS by default. Prior to 2.11.4, forward_auth copy_headers deletes the exact client-supplied identity header before copying the trusted value from the auth gateway. But when the request later goes through php_fastcgi, Caddy normalizes HTTP headers into CGI variables by replacing - with _. This lets a client send an underscore alias that survives the forward_auth delete step but becomes the same PHP/FastCGI variable. Result: a remote client can inject or sometimes override identity/group headers trusted by PHP/FastCGI applications behind Caddy. This vulnerability is fixed in 2.11.4.

Products
caddy
Affected versions
2.11.2-1, 2.11.2-1~bpo13+1, 2.6.2-12, 2.6.2-13, 2.6.2-14, 2.6.2-5
Fixed versions
2.11.4-1, 2.6.2-12+deb13u1, 2.6.2-5+deb12u1
CVEs
CVE-2026-52845
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 12:18 UTC · Revision 1

Source evidence

DEBIAN-CVE-2026-52845

core-osv · Original source

Published 23 Jun 2026, 18:18 UTC

Caddy is an extensible server platform that uses TLS by default. Prior to 2.11.4, forward_auth copy_headers deletes the exact client-supplied identity header before copying the trusted value from the auth gateway. But when the request later goes through php_fastcgi, Caddy normalizes HTTP headers into CGI variables by replacing - with _. This lets a client send an underscore alias that survives the forward_auth delete step but becomes the same PHP/FastCGI variable. Result: a remote client can inject or sometimes override identity/group headers trusted by PHP/FastCGI applications behind Caddy. This vulnerability is fixed in 2.11.4.

osv:DEBIAN-CVE-2026-52845

caddy

Fixed versions: 2.6.2-5+deb12u1

caddy

Fixed versions: 2.6.2-12+deb13u1

caddy

Fixed versions: 2.11.4-1

Complete source record
{
  "id": "be3dc0e6510e4c56ace7df8b0f7f8ebf96306e72816987910b7f9869a2c74b6a",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-52845",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2026-52845",
    "summary": "Caddy is an extensible server platform that uses TLS by default. Prior to 2.11.4, forward_auth copy_headers deletes the exact client-supplied identity header before copying the trusted value from the auth gateway. But when the request later goes through php_fastcgi, Caddy normalizes HTTP headers into CGI variables by replacing - with _. This lets a client send an underscore alias that survives the forward_auth delete step but becomes the same PHP/FastCGI variable. Result: a remote client can inject or sometimes override identity/group headers trusted by PHP/FastCGI applications behind Caddy. This vulnerability is fixed in 2.11.4.",
    "evidence": "osv:DEBIAN-CVE-2026-52845",
    "products": [
      {
        "name": {
          "value": "caddy",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.6.2-5+deb12u1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": [
          {
            "value": "2.6.2-5",
            "evidence": "/affected/0/versions"
          }
        ]
      },
      {
        "name": {
          "value": "caddy",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.6.2-12+deb13u1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": [
          {
            "value": "2.6.2-12",
            "evidence": "/affected/1/versions"
          }
        ]
      },
      {
        "name": {
          "value": "caddy",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.11.4-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": [
          {
            "value": "2.11.2-1",
            "evidence": "/affected/2/versions"
          },
          {
            "value": "2.11.2-1~bpo13+1",
            "evidence": "/affected/2/versions"
          },
          {
            "value": "2.6.2-12",
            "evidence": "/affected/2/versions"
          },
          {
            "value": "2.6.2-13",
            "evidence": "/affected/2/versions"
          },
          {
            "value": "2.6.2-14",
            "evidence": "/affected/2/versions"
          }
        ]
      }
    ],
    "severity": "high",
    "structured": {
      "id": "DEBIAN-CVE-2026-52845",
      "aliases": [
        "DEBIAN-CVE-2026-52845"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.6.2-5+deb12u1"
                }
              ]
            }
          ],
          "package": {
            "name": "caddy",
            "purl": "pkg:deb/debian/caddy?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "versions": [
            "2.6.2-5"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-52845.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.6.2-12+deb13u1"
                }
              ]
            }
          ],
          "package": {
            "name": "caddy",
            "purl": "pkg:deb/debian/caddy?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "versions": [
            "2.6.2-12"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-52845.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.11.4-1"
                }
              ]
            }
          ],
          "package": {
            "name": "caddy",
            "purl": "pkg:deb/debian/caddy?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "versions": [
            "2.11.2-1",
            "2.11.2-1~bpo13+1",
            "2.6.2-12",
            "2.6.2-13",
            "2.6.2-14"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-52845.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-26T11:47:32.044692470Z",
      "provider": "osv",
      "upstream": [
        "CVE-2026-52845"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2026-52845"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2026-52845",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 450847,
  "published_at": "2026-06-23T18:18:05.267+00:00"
}